Bug 184465 - Opening of npss file may block AWT
Opening of npss file may block AWT
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: 7.2
Assigned To: issues@profiler
issues@profiler
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-19 14:44 UTC by Egor Ushakov
Modified: 2012-04-04 13:34 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (26.50 KB, application/nps)
2010-04-19 14:44 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2010-04-19 14:44:06 UTC
Build: NetBeans IDE Dev (Build 201004190200)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: SunOS

User Comments:
schkovich: Warning was shown after stopping CPU profiling of scanning external changes.

Number of Low Performance notification has increased significantly after installing Java Profiler plug-in.

gorrus: generating performance snapshot (in AWT???)



Maximum slowness yet reported was 107540 ms, average is 55290
Comment 1 Egor Ushakov 2010-04-19 14:44:58 UTC
Created attachment 97634 [details]
nps snapshot
Comment 2 Tomas Hurka 2010-04-26 12:47:42 UTC
This problem should be solved in the latest dev. build. See issue #184680.
Comment 3 Jaroslav Tulach 2010-07-01 08:45:33 UTC
My recent report
http://statistics.netbeans.org/exceptions/exception.do?id=406549
has been classified as duplicate of this issue, but clearly it is not fixed. If I open npss file from command line, it blocks AWT. 

Preferably a window saing "Loading..." shall be shown immediately and the actual processing shall happen on background.
Comment 4 Tomas Hurka 2012-04-04 13:34:52 UTC
I am not able to reproduce it in daily build 201204040400.  I also tried opening the npss file from command line and it works fine for me.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo