Bug 184305 - [69cat] NullPointerException at org.netbeans.modules.apisupport.project.ui.customizer.BasicBrandingModel.getKeyValue
[69cat] NullPointerException at org.netbeans.modules.apisupport.project.ui.cu...
Status: RESOLVED DUPLICATE of bug 185522
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Antonin Nebuzelsky
issues@apisupport
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-15 20:25 UTC by alied
Modified: 2010-05-05 15:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.27 KB, text/plain)
2010-04-15 20:25 UTC, alied
Details
stacktrace (3.25 KB, text/plain)
2010-04-16 14:22 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alied 2010-04-15 20:25:40 UTC
Build: NetBeans IDE Dev (Build 201004140201)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows Vista

User Comments:
alied: after reporting previous exception

alied: while in the branding dialog, tried to expand a bundle




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.apisupport.project.ui.customizer.BasicBrandingModel.getKeyValue(BasicBrandingModel.java:672)
   at org.netbeans.modules.apisupport.project.ui.customizer.ResourceBundleBrandingPanel.getKeyValue(ResourceBundleBrandingPanel.java:464)
   at org.netbeans.modules.apisupport.project.ui.customizer.ResourceBundleBrandingPanel.access$700(ResourceBundleBrandingPanel.java:87)
   at org.netbeans.modules.apisupport.project.ui.customizer.ResourceBundleBrandingPanel$KeyNode.getHtmlDisplayName(ResourceBundleBrandingPanel.java:382)
   at org.openide.explorer.view.VisualizerNode.getHtmlDisplayName(VisualizerNode.java:535)
   at org.openide.explorer.view.NodeRenderer.getTreeCellRendererComponent(NodeRenderer.java:126)
Comment 1 alied 2010-04-15 20:25:47 UTC
Created attachment 97487 [details]
stacktrace
Comment 2 alied 2010-04-16 14:22:59 UTC
Created attachment 97536 [details]
stacktrace

On the branding editor, showed the context menu and selected vew all bundles
Comment 3 Antonin Nebuzelsky 2010-05-05 15:44:16 UTC

*** This bug has been marked as a duplicate of bug 185522 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo