Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 183633 - Live Template - Add Class (or FileName) template
Live Template - Add Class (or FileName) template
Status: RESOLVED DUPLICATE of bug 210454
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
http://wiki.netbeans.org/RubyCodeTemp...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-07 09:49 UTC by pfabier
Modified: 2015-03-26 22:26 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pfabier 2010-04-07 09:49:41 UTC
Hi,

Currently, we have live templates like "${param_name array}" allowing us to substitute an array variable in the live template.
We can't substitute the current filename we're editing, nor the class name.

Also, this is possible with Ruby through ${class} or ${file}.
=> http://wiki.netbeans.org/RubyCodeTemplates

I suggest to add these live templates to the Java Editor, or even to all Editors when possible (${file} for example).

Example purpose : Create a "logger" live template like this:
-- logger
private static final Logger LOGGER = Logger.getLogger(${param_name class}.getName());
Comment 1 markiewb 2015-03-26 22:26:18 UTC
Duplicate of 210454.

*** This bug has been marked as a duplicate of bug 210454 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo