Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 182950 - [69cat] Bugzilla search layout flaws
[69cat] Bugzilla search layout flaws
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
6.x
All All
: P4 (vote)
: 6.x
Assigned To: Jan Stola
issues@connecteddeveloper
: NETFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-26 18:55 UTC by Michel Graciano
Modified: 2010-04-02 10:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Sample image (17.17 KB, image/png)
2010-03-26 18:57 UTC, Michel Graciano
Details
Screenshot of Find Issue window in #20100329. (25.95 KB, image/png)
2010-03-29 11:43 UTC, Jiri Kovalsky
Details
Simple proposed patch to fix text field layout issue (2.70 KB, patch)
2010-03-29 14:28 UTC, Michel Graciano
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2010-03-26 18:55:28 UTC
[ BUILD # : c0c8da2a52b0 ]
[ JDK VERSION : 1.6.* ]

There are some issues at bz search inside the IDE.
. Issue Tracker combobox is not painted correctly, some problem with the top
border;
. Issue ID text field alignment is incorrect;
. Issue ID, Find Issues by Text and others components are gray instead to be
white. Probably it should be not opaque.

I am attaching an sample image about it.
Comment 1 Michel Graciano 2010-03-26 18:57:23 UTC
Created attachment 95997 [details]
Sample image
Comment 2 Jiri Kovalsky 2010-03-29 11:42:43 UTC
Michel, which L&F is this? Re: #1, on my L&F no border is painted at all. Re: #2, the field is high enough although not as the button next to it. Re: #3, the fact that the collapsible section headers are gray is as designed in my opinion.

See attached screenshot.
Comment 3 Jiri Kovalsky 2010-03-29 11:43:59 UTC
Created attachment 96172 [details]
Screenshot of Find Issue window in #20100329.
Comment 4 Tomas Stupka 2010-03-29 12:03:11 UTC

> . Issue Tracker combobox is not painted correctly, some problem with the top
> border;
seems to be a problem on some look and feels

> . Issue ID, Find Issues by Text and others components are gray instead to be
> white. Probably it should be not opaque.
WAD

agree - combo border and issue id alignment aren't very nice, but don't think thats a "Highly visible usability problem" -> p4
Comment 5 Michel Graciano 2010-03-29 12:09:38 UTC
I usually use Metal LAF. My workstation is an Ubuntu but I don't like GTK so I prefer to use Metal as well.
Comment 6 Michel Graciano 2010-03-29 14:28:54 UTC
Created attachment 96227 [details]
Simple proposed patch to fix text field layout issue

Well, I created an simple patch to fix the text field alignment problem. I hope you will approve this patch :)
Comment 7 Jiri Kovalsky 2010-04-01 07:14:45 UTC
Tomasi, can you please review Michel's patch of the imperfect textfield alignment? Thanks!
Comment 8 Jan Stola 2010-04-01 09:08:37 UTC
I checked the patch. It is correct.
Comment 9 Jan Stola 2010-04-01 14:08:40 UTC
I will fix the combobox problem and will integrate the attached patch (to fix the alignment problem).
Comment 10 Jan Stola 2010-04-01 15:43:23 UTC
I have fixed the problems with the combo-box and with the text-field. The gray background of some components is as designed => marking the issue as fixed.

Modified files:
http://hg.netbeans.org/cdev/rev/d0a7189e061a
http://hg.netbeans.org/cdev/rev/124d72e28707
Comment 11 Jiri Kovalsky 2010-04-02 10:56:46 UTC
Thank you Michel for your 1/2 patch and Honzo for its review and fixing the other half.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo