Bug 182946 - "Log in to team server" dialogs keep appearing
"Log in to team server" dialogs keep appearing
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Tomas Stupka
issues@connecteddeveloper
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-26 17:44 UTC by Jesse Glick
Modified: 2010-04-03 05:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (76.64 KB, image/png)
2010-03-26 17:45 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2010-03-26 17:44:48 UTC
100326-2cd226712a44. Not sure exactly what I did - I think I started to report an issue on netbeans.org/bugzilla using Team > Report Issue and then closed the window. Anyway, a dialog prompting me to log in to netbeans.org appeared. I agreed, but another one came. ESC or Cancel closes it, but more come.

I was eventually able to shut down the IDE only by holding down the ESC key for a couple of minutes until all the accumulated dialogs cleared, then clicking the close button on the main window in the ~300msec available before the next one opens.
Comment 1 Jesse Glick 2010-03-26 17:45:15 UTC
Created attachment 95993 [details]
Screenshot
Comment 2 Jesse Glick 2010-03-26 18:58:03 UTC
And an hour later, I found lots of background CPU and realized this IDE process was still running, with dozens of threads like:

"Default RequestProcessor" daemon prio=10 tid=0xade0a000 nid=0x6bc5 in Object.wait() [0xb0452000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Object.java:485)
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:993)
	- locked <0x7ef0c8c0> (a java.awt.EventQueue$1AWTInvocationLock)
	at org.openide.util.Mutex.doEventAccess(Mutex.java:1384)
	at org.openide.util.Mutex.readAccess(Mutex.java:268)
	at org.netbeans.core.windows.services.DialogDisplayerImpl.createDialog(DialogDisplayerImpl.java:107)
	at org.netbeans.modules.kenai.ui.spi.UIUtils.showKenaiLogin(UIUtils.java:267)
	at org.netbeans.modules.kenai.ui.spi.UIUtils.showKenaiLogin(UIUtils.java:163)
	at org.netbeans.modules.kenai.ui.spi.UIUtils.showLogin(UIUtils.java:153)
	at org.netbeans.modules.bugtracking.kenai.KenaiAccessorImpl.showLoginIntern(KenaiAccessorImpl.java:298)
	at org.netbeans.modules.bugtracking.kenai.KenaiAccessorImpl.getPasswordAuthentication(KenaiAccessorImpl.java:290)
	at org.netbeans.modules.bugtracking.kenai.KenaiAccessorImpl.getPasswordAuthentication(KenaiAccessorImpl.java:145)
	at org.netbeans.modules.bugtracking.kenai.spi.KenaiUtil.getPasswordAuthentication(KenaiUtil.java:101)
	at org.netbeans.modules.jira.kenai.KenaiRepository.authenticate(KenaiRepository.java:259)
	at org.netbeans.modules.jira.commands.JiraExecutor$ExceptionHandler$LoginHandler.handle(JiraExecutor.java:335)
	at org.netbeans.modules.jira.commands.JiraExecutor.execute(JiraExecutor.java:137)
	at org.netbeans.modules.jira.repository.JiraRepository.getConfigurationIntern(JiraRepository.java:520)
	at org.netbeans.modules.jira.repository.JiraRepository.getConfiguration(JiraRepository.java:487)
	- locked <0x7ead38f0> (a java.lang.Object)
	at org.netbeans.modules.jira.kenai.KenaiSupportImpl.createRepository(KenaiSupportImpl.java:95)
	at org.netbeans.modules.bugtracking.kenai.spi.KenaiRepositories.getRepository(KenaiRepositories.java:109)
	at org.netbeans.modules.bugtracking.kenai.spi.KenaiRepositories.getRepository(KenaiRepositories.java:87)
	at org.netbeans.modules.bugtracking.kenai.spi.KenaiRepositories$DefaultImpl.getRepositories(KenaiRepositories.java:162)
	at org.netbeans.modules.bugtracking.kenai.spi.KenaiUtil.getRepositories(KenaiUtil.java:160)
	at org.netbeans.modules.bugtracking.BugtrackingManager.getKnownRepositories(BugtrackingManager.java:119)
	at org.netbeans.modules.bugtracking.util.BugtrackingUtil.getKnownRepositories(BugtrackingUtil.java:261)
	at org.netbeans.modules.bugtracking.util.RepositoryComboSupport.loadRepositories(RepositoryComboSupport.java:600)
	at org.netbeans.modules.bugtracking.util.RepositoryComboSupport.access$700(RepositoryComboSupport.java:79)
	at org.netbeans.modules.bugtracking.util.RepositoryComboSupport$3.run(RepositoryComboSupport.java:583)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1369)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1907)
Comment 3 Jan Becicka 2010-03-29 08:32:58 UTC
Bugtracking module seems to invoke this dialog
Comment 4 Tomas Stupka 2010-03-30 10:46:49 UTC
what are your proxy settings? in case of manual - do you have any http/https proxies set?
Comment 5 Jesse Glick 2010-03-31 03:54:25 UTC
I do not use any proxy.
Comment 6 Tomas Stupka 2010-04-02 14:32:18 UTC
1.) several bugtracking subsystems may try to create repositories for all projects from the dashboard at once so the effect is that kenai repositories are created more then once for each project at the same time. That is definitely wrong and could explain all the running tasks. The login request was made because of jira which demands a login prior a repository configuration access. Will fix by serializing access to KenaiSupport.createRepository() for each registered kenai instance and bugtracking type. No negative performance impact is expected. More in the opposite - initially when no repository configuration is available yet, it will be loaded only once for all projects on a kenai server.

one more thing to mention:
2.) it looks like you haven't been logged into kenai when you invoked Team > Find issue but there already where some projects opened in the dashboard. The disturbing part is that the relevant jira repository configuration wasn't downloaded at that moment. Do you remember if you logged in and out from kenai in a brief sequence or could it be that you removed some files from your userdir?
Comment 7 Tomas Stupka 2010-04-02 17:05:09 UTC
fixed
Changeset: 6ea4d186863d
Comment 8 Tomas Stupka 2010-04-02 17:09:48 UTC
another strange thing were the hanging tasks even after the login popups where closed. Tried to reproduce after the fix, but without success. Will keep this as resolved for now.
Comment 9 Jesse Glick 2010-04-02 17:12:30 UTC
(In reply to comment #6)
> Do you remember if you logged in and out from kenai
> in a brief sequence

I don't think so.

> could it be that you removed some files from your userdir?

Not that I know of.
Comment 10 Quality Engineering 2010-04-03 05:29:46 UTC
Integrated into 'main-golden', will be available in build *201004030201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6ea4d186863d
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #182946 - "Log in to team server" dialogs keep appearing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo