Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 182544 - Hint invocation caused java.lang.ArrayIndexOutOfBoundsException
Hint invocation caused java.lang.ArrayIndexOutOfBoundsException
Status: CLOSED DUPLICATE of bug 182542
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jan Lahoda
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-23 08:26 UTC by Jaromir Uhrik
Modified: 2010-03-23 08:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2010-03-23 08:26:42 UTC
Product Version = NetBeans IDE Dev (Build 201003220200)
Operating System = Mac OS X version 10.5.8 running on x86_64
Java; VM; Vendor = 1.6.0_17
Runtime = Java HotSpot(TM) 64-Bit Server VM 14.3-b01-101

-create class NewClass
-let's write the following NewClass body to this class:
	public class NewClass{
		public void NewClass(String s){ System.out.println("s"); }
	}
-go to the line with constructor and push Alt-Enter to invoke hint popup
-push Enter to activate hint

-->>Following Exception appears:
java.lang.ArrayIndexOutOfBoundsException: -1
	at org.netbeans.modules.java.source.pretty.CharBuffer.eatAwayChars(CharBuffer.java:263)
	at org.netbeans.modules.java.source.pretty.VeryPretty.eatChars(VeryPretty.java:1705)
	at org.netbeans.modules.java.source.save.CasualDiff.copyTo(CasualDiff.java:3404)
	at org.netbeans.modules.java.source.save.CasualDiff.copyTo(CasualDiff.java:3392)
	at org.netbeans.modules.java.source.save.CasualDiff.diffMethodDef(CasualDiff.java:655)
	at org.netbeans.modules.java.source.save.CasualDiff.diffTreeImpl(CasualDiff.java:2944)
	at org.netbeans.modules.java.source.save.CasualDiff.diffTree(CasualDiff.java:2892)
	at org.netbeans.modules.java.source.save.CasualDiff.diff(CasualDiff.java:186)
	at org.netbeans.api.java.source.WorkingCopy.processCurrentCompilationUnit(WorkingCopy.java:444)
	at org.netbeans.api.java.source.WorkingCopy.getChanges(WorkingCopy.java:505)
	at org.netbeans.api.java.source.JavaSource$1.run(JavaSource.java:665)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:151)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:135)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:190)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:103)
	at org.netbeans.api.java.source.JavaSource.runModificationTask(JavaSource.java:677)
	at org.netbeans.modules.java.hints.SystemOut$FixImpl.implement(SystemOut.java:118)
	at org.netbeans.modules.editor.hints.HintsUI$1.run(HintsUI.java:715)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1356)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1894)
	at org.netbeans.modules.java.source.pretty.CharBuffer.eatAwayChars(CharBuffer.java:263)
	at org.netbeans.modules.java.source.pretty.VeryPretty.eatChars(VeryPretty.java:1705)
	at org.netbeans.modules.java.source.save.CasualDiff.copyTo(CasualDiff.java:3404)
	at org.netbeans.modules.java.source.save.CasualDiff.copyTo(CasualDiff.java:3392)
	at org.netbeans.modules.java.source.save.CasualDiff.diffMethodDef(CasualDiff.java:655)
	at org.netbeans.modules.java.source.save.CasualDiff.diffTreeImpl(CasualDiff.java:2944)
	at org.netbeans.modules.java.source.save.CasualDiff.diffTree(CasualDiff.java:2892)
	at org.netbeans.modules.java.source.save.CasualDiff.diff(CasualDiff.java:186)
	at org.netbeans.api.java.source.WorkingCopy.processCurrentCompilationUnit(WorkingCopy.java:444)
	at org.netbeans.api.java.source.WorkingCopy.getChanges(WorkingCopy.java:505)
	at org.netbeans.api.java.source.JavaSource$1.run(JavaSource.java:665)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:151)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:135)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:190)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:103)
	at org.netbeans.api.java.source.JavaSource.runModificationTask(JavaSource.java:677)
	at org.netbeans.modules.java.hints.SystemOut$FixImpl.implement(SystemOut.java:118)
	at org.netbeans.modules.editor.hints.HintsUI$1.run(HintsUI.java:715)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1356)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1894)
Comment 1 Jaromir Uhrik 2010-03-23 08:47:32 UTC

*** This bug has been marked as a duplicate of bug 182542 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo