Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 181862 - Wrong order of toolCollectors initialization
Wrong order of toolCollectors initialization
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: D-Light
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: Andrew Krasny
dlight-issues@cnd
68patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-11 08:36 UTC by Andrew Krasny
Modified: 2010-03-19 12:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (4.86 KB, patch)
2010-03-11 08:38 UTC, Andrew Krasny
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2010-03-11 08:36:45 UTC
This is required for dlight project and needs to be done in 6.8 patch2.
[changes are not applicable to 6.9]

The problem is that init() method of toolCollector called _before_ IndicatorDataProvider's init (which initializes serviceInfoDataStorage). But in case if toolCollector implements IndicatorDataProvider interface it may want to access serviceInfoDataStorage in it's init... 

The fix is in attachment.
Comment 1 Andrew Krasny 2010-03-11 08:38:54 UTC
Created attachment 95049 [details]
proposed patch
Comment 2 Andrew Krasny 2010-03-11 08:41:24 UTC
Proposed fix is attached.
Maria, could you, please review and set 'verified' status...
Comment 3 Maria Tishkova 2010-03-11 08:43:14 UTC
reviewed, fix is OK
Comment 4 pgebauer 2010-03-15 18:16:54 UTC
The fix has been ported into the release68_fixes branch.
http://hg.netbeans.org/release68_fixes/rev/81e1cc5191d8
Comment 5 Alexander Pepin 2010-03-19 12:23:04 UTC
verified in patch2 candidate 20100318


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo