Bug 181703 - Allow prioritizing parameters in a code-template
Allow prioritizing parameters in a code-template
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
PC All
: P3 with 1 vote (vote)
: 8.2
Assigned To: markiewb
issues@editor
: NETFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-09 09:54 UTC by David Kaspar
Modified: 2016-08-18 01:49 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed patch v2 (9.49 KB, patch)
2016-08-10 22:44 UTC, markiewb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Kaspar 2010-03-09 09:54:55 UTC
Imagine the following code-template:

for (Object ${x default="item"} : ${y default="items"}) {
}

I would like to specify that the "items" should be edited before editing "item" parameter since its name may be derived from the name of "items" parameter.
Comment 1 Martin Balin 2016-07-07 07:28:13 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss
Comment 2 markiewb 2016-07-10 18:20:48 UTC
Still valid in 8.2 dev 
Product Version: NetBeans IDE Dev (Build 201607100002)
Comment 3 markiewb 2016-08-10 22:44:23 UTC
Created attachment 161626 [details]
Proposed patch v2

@Dusan/@Miloslav: Can you please review the patch before I commit the code!
Comment 4 markiewb 2016-08-15 21:37:18 UTC
Fixed. Thanks for the review Miloslav!

http://hg.netbeans.org/core-main/rev/9835e4536c2d
Comment 5 markiewb 2016-08-16 17:24:31 UTC
Sigtest failed. 
* Updated version to 1.43. 
* Updated apichanges.xml

http://hg.netbeans.org/core-main/rev/9e739feebca1
Comment 6 Quality Engineering 2016-08-18 01:49:18 UTC
Integrated into 'main-silver', will be available in build *201608180002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/9835e4536c2d
User: Benno Markiewicz <markiewb@netbeans.org>
Log: #181703 - Allow prioritizing parameters in a code-template

* introduced 'ordering' attribute, f.e. '${paramC ordering=1}'
* updated fore-templates in java.editor/groovy.editor


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo