Bug 181533 - Usability problems with heavyweight tooltips
Usability problems with heavyweight tooltips
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
: API, API_REVIEW_FAST
: 182120 (view as bug list)
Depends on: 182120
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-04 09:03 UTC by Martin Entlicher
Modified: 2010-10-04 12:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Heavyweight tooltips support (13.95 KB, patch)
2010-05-05 12:49 UTC, Vitezslav Stejskal
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2010-03-04 09:03:56 UTC
After issue #59336 was resolved, when we display detailed variable information in a component tooltip from debugger, the component disappears as soon as the user exits the component with a mouse. This can be unexpected.

Also the component tooltip disappears when the mouse happens to be outside of the tooltip component when the tooltip is opened.

The solution could be to close the component tooltip after user clicks somewhere into the Editor.
Comment 1 Martin Entlicher 2010-03-04 09:04:46 UTC
Also we need a way to disable the timer so that the component does not unexpectedly disappears.
Comment 2 Vitezslav Stejskal 2010-03-05 02:41:49 UTC
#1 - heavyweight tooltips should only be closed explicitly by a user (eg. when they press ESC or click outside of the tooltip)

#2 - the exitTimer should be disabled for heavyweight tooltips

#3 - when a heavyweight tooltip is shown no other editor tooltips can be shown (the hwt has first to be closed by the user as per #1)

If there are other problems, please add them to the list.
Comment 3 Tomas Pavek 2010-04-29 14:53:19 UTC
ad #1 - the heavy tooltip after clicking the + button often opens below the mouse cursor and so disappears after trying to move the mouse on it. In most cases this makes the tooltip unusable. IMHO it should be solved for 6.9 release.
Comment 4 Petr Suchomel 2010-04-29 15:30:45 UTC
A comment from the customer (I will not translate, you'll understand)
"ještě jsem narazil na vtipnou kosmetiku – hinty debuggeru
  docílí se toho takto: Najedu při debugování myší nad proměnnou a zobrazí se mi hint s [+] na rozbalení informací viz obr.
  Pokud se ta proměnná nachází dostatečně nahoře v okně editoru, tak se informace rozbalí směrem dolů. Protože ale myš není
  nad tímto popupem, tak se při pohybu popup hned zavře.
  Pokud jsem ale s proměnnou dost dole, tak se detail popup otevře směrem nahoru a tím pádem je myš nad ním, takže si můžu v
  klidu rozklinkávat další prvky a všechno je OK."
Comment 5 Vitezslav Stejskal 2010-05-05 12:49:12 UTC
Created attachment 98487 [details]
Heavyweight tooltips support

A patch that enhances ToolTipSupport to support heavyweight tooltips. It adds several public constants (flags) and a new setTooltip() method with the additional 'flags' parameter. This method is called from debugger's ToolTipAnnotation.
Comment 6 Vitezslav Stejskal 2010-05-05 12:50:24 UTC
Please review this simple addition to editor's ToolTipSupport.
Comment 7 Vitezslav Stejskal 2010-05-10 13:31:11 UTC
http://hg.netbeans.org/jet-main/rev/46679b74d88b
Comment 8 Quality Engineering 2010-05-12 04:14:35 UTC
Integrated into 'main-golden', will be available in build *201005112200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:
Comment 9 David Strupl 2010-10-04 12:47:06 UTC
*** Bug 182120 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo