Bug 181516 - Error when putting break point to debug a php application
Error when putting break point to debug a php application
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC Windows 7
: P2 (vote)
: 6.x
Assigned To: rmatous
issues@php
: PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-04 04:36 UTC by dahan
Modified: 2011-11-16 16:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Error when debugging in httpd (238.93 KB, image/jpeg)
2010-03-15 14:41 UTC, dahan
Details
second print screen (179.26 KB, image/jpeg)
2010-03-15 14:44 UTC, dahan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dahan 2010-03-04 04:36:28 UTC
SEVERE [org.netbeans.modules.php.dbgp.DebugSession]
java.lang.AssertionError
	at org.netbeans.modules.php.dbgp.DebugSession.initConnection(DebugSession.java:191)
	at org.netbeans.modules.php.dbgp.packets.InitMessage.setId(InitMessage.java:165)
	at org.netbeans.modules.php.dbgp.packets.InitMessage.process(InitMessage.java:82)
	at org.netbeans.modules.php.dbgp.DebugSession.handleMessage(DebugSession.java:276)
	at org.netbeans.modules.php.dbgp.DebugSession.receiveData(DebugSession.java:262)
	at org.netbeans.modules.php.dbgp.DebugSession.receiveData(DebugSession.java:252)
	at org.netbeans.modules.php.dbgp.DebugSession.run(DebugSession.java:140)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
[catch] at java.lang.Thread.run(Thread.java:619)
INFO [org.netbeans.modules.php.dbgp.DebugSession]
java.net.SocketException: Socket is closed
	at java.net.Socket.getInputStream(Socket.java:774)
	at org.netbeans.modules.php.dbgp.DebugSession.receiveData(DebugSession.java:259)
	at org.netbeans.modules.php.dbgp.DebugSession.receiveData(DebugSession.java:252)
	at org.netbeans.modules.php.dbgp.DebugSession.run(DebugSession.java:140)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
[catch] at java.lang.Thread.run(Thread.java:619)
Comment 1 dahan 2010-03-09 01:13:17 UTC
This debug error occurred when I used 6.9 M1
In this version, I cannot debug anything ..
The debugger is not working well.
I don't have this error in 6.8 so I'm back to use it
Comment 2 rmatous 2010-03-15 11:39:05 UTC
Not reproducible for me.

Looks like this bug appears just in case during session initialization not matching Session ID (or called idekey)

Do you use FireFox 2 extension that allows you to trigger Xdebug's debugger without having to use XDEBUG_SESSION_START as parameter? If so, then you must configure IDE key it uses.

Anyway assertion removed, please verify or reopen 

http://hg.netbeans.org/web-main/rev/e3fbcfec4cd2
Comment 3 dahan 2010-03-15 12:38:44 UTC
No, I'm use FireFox 2 extension.

Well, how to test it?
I should download the version 6.9 M1 or the latest development build ?
Or special build ? (if special build, please semd me the URL to download it.
Comment 4 dahan 2010-03-15 12:57:31 UTC
(In reply to comment #3)
> No, I'm use FireFox 2 extension.
> 
> Well, how to test it?
> I should download the version 6.9 M1 or the latest development build ?
> Or special build ? (if special build, please semd me the URL to download it.

Sorry, I mean: I'm NOT using FireFox 2 Extension

Where to find the new fixed version of NetBeans to test it?
Comment 5 rmatous 2010-03-15 13:50:15 UTC
Build 1529 or newer:
http://bertram.netbeans.org/hudson/job/PHP-build/1529/
Comment 6 dahan 2010-03-15 14:41:51 UTC
Created attachment 95186 [details]
Error when debugging in httpd

The bug is not fixed ..
I attached a printscreen
Comment 7 dahan 2010-03-15 14:44:00 UTC
Created attachment 95187 [details]
second print screen
Comment 8 rmatous 2010-03-15 14:58:20 UTC
hmm, crash in httpd.exe seems not to be a bug in Netbeans IDE. Probably should be reported against xdebug
Comment 9 Quality Engineering 2010-03-16 05:15:43 UTC
Integrated into 'main-golden', will be available in build *201003160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e3fbcfec4cd2
User: Radek Matous <rmatous@netbeans.org>
Log: #181516  -  Error when putting break point to debug a php application


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo