Bug 180957 - [68cat] IndexOutOfBoundsException: Index: 3, Size: 3
[68cat] IndexOutOfBoundsException: Index: 3, Size: 3
Status: RESOLVED DUPLICATE of bug 180960
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@platform
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-19 05:15 UTC by neilg
Modified: 2010-09-30 20:02 UTC (History)
39 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.63 KB, text/plain)
2010-02-19 05:16 UTC, neilg
Details
stacktrace (5.32 KB, text/plain)
2010-02-25 03:59 UTC, lolo_101
Details
stacktrace (4.63 KB, text/plain)
2010-03-18 10:22 UTC, kawazu428
Details
stacktrace (4.62 KB, text/plain)
2010-03-18 11:28 UTC, kawazu428
Details
stacktrace (4.54 KB, text/plain)
2010-03-24 06:27 UTC, esmithbss
Details
stacktrace (4.53 KB, text/plain)
2010-03-30 04:07 UTC, esmithbss
Details
stacktrace (4.54 KB, text/plain)
2010-04-01 08:53 UTC, esmithbss
Details
stacktrace (2.71 KB, text/plain)
2010-04-06 16:52 UTC, jasondonmoyer
Details
stacktrace (2.27 KB, text/plain)
2010-04-14 21:19 UTC, jasondonmoyer
Details
stacktrace (4.71 KB, text/plain)
2010-04-29 07:41 UTC, Jan Lahoda
Details
stacktrace (4.72 KB, text/plain)
2010-05-03 14:47 UTC, host
Details
stacktrace (3.75 KB, text/plain)
2010-05-04 16:11 UTC, swpalmer
Details
stacktrace (5.51 KB, text/plain)
2010-05-07 13:58 UTC, Alexey Vladykin
Details
stacktrace (6.48 KB, text/plain)
2010-05-11 16:58 UTC, Petr Jiricka
Details
stacktrace (2.71 KB, text/plain)
2010-05-13 15:01 UTC, jasondonmoyer
Details
stacktrace (5.54 KB, text/plain)
2010-05-25 21:44 UTC, swpalmer
Details
stacktrace (4.71 KB, text/plain)
2010-08-16 16:17 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description neilg 2010-02-19 05:15:56 UTC
Build: NetBeans IDE Dev (Build 201002152000)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Linux

User Comments:
neilg: Typing in a java source file




Stacktrace: 
java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
   at java.util.ArrayList.RangeCheck(ArrayList.java:547)
   at java.util.ArrayList.get(ArrayList.java:322)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.fireContentsChanged(DefaultTabDataModel.java:454)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.setText(DefaultTabDataModel.java:159)
   at org.netbeans.swing.tabcontrol.TabbedContainer.setTitleAt(TabbedContainer.java:701)
   at org.netbeans.core.windows.view.ui.TabbedHandler.topComponentNameChanged(TabbedHandler.java:236)
Comment 1 neilg 2010-02-19 05:16:00 UTC
Created attachment 94328 [details]
stacktrace
Comment 2 lolo_101 2010-02-25 03:59:52 UTC
Created attachment 94508 [details]
stacktrace

Opened the Form Designer
Comment 3 kawazu428 2010-03-18 10:22:32 UTC
Created attachment 95357 [details]
stacktrace

removed a piece of code in a .java code line?
Comment 4 kawazu428 2010-03-18 11:28:33 UTC
Created attachment 95360 [details]
stacktrace

commenting out a line of .java code
Comment 5 esmithbss 2010-03-24 06:27:18 UTC
Created attachment 95632 [details]
stacktrace

Just swapped back into the IDE from an external command line window.

Switched to a specific file  in my list.

Hit the Enter Key 2 times.

This exception popped up.
Comment 6 esmithbss 2010-03-30 04:07:38 UTC
Created attachment 96295 [details]
stacktrace

Cutting and pasting one line into a rails model class.
Comment 7 esmithbss 2010-04-01 08:53:12 UTC
Created attachment 96501 [details]
stacktrace

Adding some lines to the application_controller class in a Rails application.
Comment 8 jasondonmoyer 2010-04-06 16:52:15 UTC
Created attachment 96799 [details]
stacktrace

I tried to go to line in the java editor (ctrl-alt-g) while a find usages was running
Comment 9 jasondonmoyer 2010-04-14 21:19:44 UTC
Created attachment 97398 [details]
stacktrace

stopped the debugger
Comment 10 Jan Lahoda 2010-04-29 07:41:17 UTC
Created attachment 98245 [details]
stacktrace
Comment 11 host 2010-05-03 14:47:17 UTC
Created attachment 98372 [details]
stacktrace
Comment 12 swpalmer 2010-05-04 16:11:36 UTC
Created attachment 98446 [details]
stacktrace

Opened form
Comment 13 Alexey Vladykin 2010-05-07 13:58:12 UTC
Created attachment 98629 [details]
stacktrace

When editing a form used undo (Ctrl+Z) several times and then hit Ctrl+S
Comment 14 Petr Jiricka 2010-05-11 16:58:23 UTC
Created attachment 98789 [details]
stacktrace

1. Closed a tab with a modified file
2. In the "Save changes?" dialog, clicked Yes.
Comment 15 jasondonmoyer 2010-05-13 15:01:31 UTC
Created attachment 98959 [details]
stacktrace

waiting for the debugger to close
Comment 16 weolopez 2010-05-14 15:16:08 UTC
removed from CC list
Comment 17 swpalmer 2010-05-25 21:44:32 UTC
Created attachment 99464 [details]
stacktrace

editing java code
Comment 18 stefan79 2010-08-16 16:17:32 UTC
Created attachment 101422 [details]
stacktrace

Editing a Java-File.
Comment 19 tboerkel 2010-09-29 12:18:23 UTC
This bug is annoying. Could the please be raised in priority and fixed in NB 6.9.1 by update?
Comment 20 Stanislav Aubrecht 2010-09-29 13:18:12 UTC

*** This bug has been marked as a duplicate of bug 180960 ***
Comment 21 Marian Petras 2010-09-30 20:02:58 UTC
I just reopened bug 180960 (still having the highest priority).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo