Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 180882 - Need visual difference between leading tabs vs. spaces
Need visual difference between leading tabs vs. spaces
Status: RESOLVED DUPLICATE of bug 4619
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-17 23:13 UTC by janicki
Modified: 2010-02-18 07:17 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description janicki 2010-02-17 23:13:19 UTC
I have configured the IDE to indent via tabs (size=2).  Sometimes while editing files (especially in a shared development environment) I'll notice that someone used two spaces instead of a tab, but it's not readily apparent.  

One solution is to show tabs visually, perhaps as a very light grey arrow.  Or to be more clever, the IDE could only make tabs or spaces visible when they aren't expected, e.g. spaces indenting lines in a normally tab-indented file could show up as yellow, or similarly highlight tabs indenting a normally space-indented file.  

Also, maybe visually draw tabs whenever they appear in the middle or end of a line (not as an indent).  I don't think there is any reason for them to (ever?) be used there.
Comment 1 Vitezslav Stejskal 2010-02-18 07:17:08 UTC
IMO duplicate of issue #4619.

*** This bug has been marked as a duplicate of bug 4619 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo