Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 179063 - cannot see jsp variables
cannot see jsp variables
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Debugger
6.x
PC Windows 7 x64
: P3 (vote)
: 7.0
Assigned To: Martin Entlicher
issues@javaee
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-27 16:07 UTC by emiddio
Modified: 2010-07-09 23:58 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
show debugger info for jsp page (370.42 KB, image/jpeg)
2009-12-27 16:07 UTC, emiddio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emiddio 2009-12-27 16:07:38 UTC
Created attachment 92947 [details]
show debugger info for jsp page

see jpeg; how do i step thru jsp code and see variable values?

it appears that the debugger is trying to show me some data, but
cannot find it.

also -- where in the variables pane would i look for jsp variables?
Comment 1 Martin Entlicher 2010-05-18 12:34:02 UTC
Reproduced. Looks like a bug of Java evaluator.
Comment 2 Martin Entlicher 2010-05-21 11:50:00 UTC
There are several problem in Java evaluator that cause a failure.
But even when they are fixed, the evaluation fails with:
"Can't assign org.apache.jasper.runtime.PageContextImpl to javax.servlet.jsp.el.VariableResolver"
This is a problem in the expression, not Java debugger.

It looks like this could not ever work.
Comment 3 Martin Entlicher 2010-05-21 13:37:44 UTC
Fixed in changeset:   171819:9bb9eed526e4 and 
changeset:   171820:0eb91f71fe6a

http://hg.netbeans.org/main/rev/9bb9eed526e4
http://hg.netbeans.org/main/rev/0eb91f71fe6a
Comment 4 rbalada 2010-06-16 08:53:06 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 5 rbalada 2010-06-21 16:01:13 UTC
Please verify bugfix for this bug, so it can be integrated into release691 repository.

Thanks,
-R
Comment 6 rbalada 2010-06-25 06:16:27 UTC
Last chance for inclusion in release691.

Please verify within 4 hours from now, since I have got limited time to transplant remaining bugfixes into release691 repository. June 25, 1 PM Prague time is my deadline. After that time, please do also the transplant/porting work if you want to include it.

Thank you for understanding,
-R
Comment 7 rbalada 2010-06-28 09:41:54 UTC
main #9bb9eed526e4 transplanted to release691 #ed80b25981f0
main #0eb91f71fe6a transplanted to release691 #88054ac28039


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo