Bug 178838 - Unable to run project and IDE hangs
Unable to run project and IDE hangs
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: J Bachorik
issues@javafx
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 03:51 UTC by Alexandr Scherbatiy
Modified: 2010-01-26 06:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread Dump (108.16 KB, text/plain)
2009-12-18 03:53 UTC, Alexandr Scherbatiy
Details
One more Thread Dump (110.54 KB, text/plain)
2009-12-23 03:26 UTC, Alexandr Scherbatiy
Details
Thread Dump when the IDE hangs (110.98 KB, text/plain)
2009-12-23 03:27 UTC, Alexandr Scherbatiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2009-12-18 03:51:34 UTC
NetBeans-JavaFX-Soma: #69

  Product Version         = NetBeans IDE 6.8 (Build 200912041610)
(#ec9be6a6486c)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02; Sun
Microsystems Inc.


I created the MediaBox sample and run it.
After that I cleaned the project and run it.
The project did not run with the message "Wait Classpath Scanning"
but class path was not scanned at that moment.

After that I prees the close button on the IDE and IDE Hanged.
Comment 1 Alexandr Scherbatiy 2009-12-18 03:53:09 UTC
Created attachment 92745 [details]
Thread Dump
Comment 2 Alexandr Scherbatiy 2009-12-18 03:54:09 UTC
From the thread dump.

"JavaFX Error Annotator Worker Thread" prio=6 tid=0x05c12800 nid=0x2c4 runnable [0x0681b000]
   java.lang.Thread.State: RUNNABLE
	at java.io.WinNTFileSystem.getBooleanAttributes(Native Method)
	at java.io.File.exists(File.java:733)
	at org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.exists(FileChangedManager.java:97)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.touchExists(FileObjectFactory.java:364)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.issueIfExist(FileObjectFactory.java:303)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.getFileObject(FileObjectFactory.java:189)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.getValidFileObject(FileObjectFactory.java:632)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getFileObject(FolderObj.java:107)
	at org.netbeans.modules.parsing.spi.indexing.support.QuerySupport.<init>(QuerySupport.java:346)
	at org.netbeans.modules.parsing.spi.indexing.support.QuerySupport.forRoots(QuerySupport.java:231)
	at org.netbeans.api.javafx.source.ClassIndex.getUsageQuery(ClassIndex.java:506)
	at org.netbeans.api.javafx.source.ClassIndex.getResources(ClassIndex.java:445)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator.doProcess(FXErrorAnnotator.java:312)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator.access$300(FXErrorAnnotator.java:88)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator$3.run(FXErrorAnnotator.java:315)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator$3.run(FXErrorAnnotator.java:313)
	at org.netbeans.modules.javafx.source.parsing.LegacyUserTask.run(LegacyUserTask.java:68)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:129)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:113)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:190)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:99)
	at org.netbeans.api.javafx.source.JavaFXSource.runUserActionTask(JavaFXSource.java:250)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator.doProcess(FXErrorAnnotator.java:313)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator.access$300(FXErrorAnnotator.java:88)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator$3.run(FXErrorAnnotator.java:315)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator$3.run(FXErrorAnnotator.java:313)
	at org.netbeans.modules.javafx.source.parsing.LegacyUserTask.run(LegacyUserTask.java:68)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:129)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:113)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:190)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:99)
Comment 3 Adam Sotona 2009-12-18 04:23:44 UTC
Yep, JavaFX Error Annotator Worker Thread does not look very healthy.
Reassigning...
Comment 4 Alexandr Scherbatiy 2009-12-23 03:26:05 UTC
Created attachment 92881 [details]
One more Thread Dump
Comment 5 Alexandr Scherbatiy 2009-12-23 03:26:55 UTC
The IDE hangs after closing.
Comment 6 Alexandr Scherbatiy 2009-12-23 03:27:53 UTC
Created attachment 92882 [details]
Thread  Dump when the IDE hangs
Comment 7 J Bachorik 2010-01-04 05:41:43 UTC
Attempted to fix in http://hg.netbeans.org/javafx/rev/6c5faa31679b

The algorithm is sped-up and it uses an iterative rather than a recursive approach. According to my measurements it yields cca. 80% time savings but I would like to ask the reporter to confirm.
Comment 8 rbalada 2010-01-21 05:31:50 UTC
Please verify this fix, so it can be included as part of fix for issue 179013
Comment 9 Alexandr Scherbatiy 2010-01-21 06:43:36 UTC
unable to reproduce the issue.

verified in NetBeans-JavaFX-Soma: #122  (Jan 21, 2010 12:00:49 AM)
Comment 10 rbalada 2010-01-21 06:59:16 UTC
The fix has been ported to release68_fixes branch as
http://hg.netbeans.org/javafx/rev/852d9e25c7ef

(changeset shared with #178404 and #179013)
Comment 11 Alexandr Scherbatiy 2010-01-26 06:45:06 UTC
unable to reproduce the issue in the NB 6.8 patch1  2010-01-25_21-27-59


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo