Bug 178816 - reply from xdebug is throwing socket exception when breakpoint is reached
reply from xdebug is throwing socket exception when breakpoint is reached
Status: RESOLVED DUPLICATE of bug 180252
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC Linux
: P3 with 1 vote (vote)
: 6.x
Assigned To: rmatous
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-17 17:51 UTC by dnessett
Modified: 2011-11-16 16:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
tar file with xdebug.log and messages.log documenting problem (9.03 KB, application/x-tar)
2009-12-17 17:51 UTC, dnessett
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dnessett 2009-12-17 17:51:12 UTC
Created attachment 92733 [details]
tar file with xdebug.log and messages.log documenting problem

Sporadically, communications from xdebug to netbeans causes a socket exception in the netbeans debugger. By sporadically, I mean sometimes breakpoints do not cause this behavior, but there are reproducible cases when it does. I originally reported this problem in the PHP forum, but decided it was better handled as a bug report.

I have attached an tar file containing xdebug.log and messages.log files that document the activity causing the socket exception.

This problem occurred on Ububtu Hardy Heron (8.04) with updates current on 16 Dec. 2009. The netbeans version information is:

Product Version: NetBeans IDE 6.8 (Build 200912041610) 
Java: 1.6.0_17; Java HotSpot(TM) Client VM 14.3-b01 
System: Linux version 2.6.24-25-generic running on i386; UTF-8; en_US (nb)
Comment 1 wedgedkc 2010-01-11 16:19:36 UTC
I'm having issues similar to this with the latest xdebug from svn. I've logged an issue [1] for xdebug but maybe it's a netbeans issue. I'm not sure...


[1] http://bugs.xdebug.org/view.php?id=520
Comment 2 rmatous 2010-02-22 08:37:02 UTC
duplicate of #180252

Looks pretty stable now, but anyway please reopen if still doesn't work for you.

NB Builds for testing:
http://bertram.netbeans.org/hudson/job/PHP-build/ 

xdebug:
tested on the latest dev builds

*** This bug has been marked as a duplicate of bug 180252 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo