Bug 178802 - JavaDB is not configured till GlassFish is activated
JavaDB is not configured till GlassFish is activated
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Derby
6.x
PC Mac OS X
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
: ERGONOMICS
: 162669 (view as bug list)
Depends on: 181635
Blocks: 226287
  Show dependency treegraph
 
Reported: 2009-12-17 11:29 UTC by Jiri Rechtacek
Modified: 2013-02-18 16:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (146.77 KB, image/png)
2010-03-08 10:15 UTC, rbalada
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2009-12-17 11:29:34 UTC
Full NetBeans 6.8 IDE with GlassFish
When I go to Services and right-click on JavaDB and choose Properties, I
expected to see the properties filled in but I see empty fields.
Comment 1 rbalada 2010-03-08 10:15:02 UTC
Created attachment 94870 [details]
Screenshot
Comment 2 Jiri Rechtacek 2010-03-09 02:39:53 UTC
*** Bug 162669 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Rechtacek 2010-03-09 02:42:22 UTC
core-main/rev/ed84ff1edba1 - moved Java DB from java cluster to ide cluster to allow using Java DB for non-java users w/o active java cluster
Registration of Java DB will be solved by automatic registration while installation of NB IDE - issue 181635
Comment 4 Quality Engineering 2010-03-10 23:14:43 UTC
Integrated into 'main-golden', will be available in build *201003110200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ed84ff1edba1
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #178802: move Java DB to ide cluster, not need to activate java features to start using Java DB, allow to use Java DB out-of-box
Comment 5 Petr Jiricka 2010-03-12 05:04:10 UTC
Still does not work for me in the following scenario:
1. Install NetBeans from the zip file and start with a fresh userdir
2. Go to Window -> Services and add GlassFish v3

I would expect that at this point, the JavaDB location will be initialized using the JavaDB instance in GlassFish, the sample database will be added etc, but it is not. To workaround this, you need to activate the Java EE features (Java SE is not enough), after that JavaDB will be initialized.
Comment 6 Jiri Rechtacek 2010-03-12 05:25:19 UTC
Petr, you are right. It's on half way, rest of solution is waiting to impl. issue 181635.
Comment 7 Jiri Rechtacek 2010-03-18 09:54:02 UTC
The last comment was filed as issue 182284. If using IDE+GF installer, JavaDB is configured directly, not need to activate Java EE anymore. Fixed in NetBeans IDE Dev (Build 201003180200)
Comment 8 Petr Jiricka 2010-03-18 12:49:55 UTC
I confirmed the fix on Mac, installer now correctly registers JavaDB when GlassFish is installed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo