Bug 178792 - "profiled application does not respond" dialog
"profiled application does not respond" dialog
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Engine
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Hurka
issues@profiler
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-17 08:06 UTC by Tomas Hurka
Modified: 2010-07-02 00:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Hurka 2009-12-17 08:06:30 UTC
See VisualVM issue #346
(https://visualvm.dev.java.net/issues/show_bug.cgi?id=346) for more details.
Comment 1 Tomas Hurka 2009-12-17 10:04:40 UTC
There seems to be performance bug in retransform classes code in JVM, which redefine classes even if the bytecode is the same. In case of  NetBeans profiler, this produces a long (= several minutes) running VM operation, which blocks all Java threads. This explains timeout in JMX connection and the profiler's dialog with "profiled application does not respond". I plan to work-around it in the profiler code.
Comment 2 Tomas Hurka 2009-12-21 07:05:52 UTC
Fixed in profiler-main. 
The long transaction is broken into several smaller ones and redefinition of unchanged classes is prevented too.

changeset:   155901:ee5a4dcb04e1
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Dec 21 12:07:00 2009 +0100
summary:     bugfix #178771 and #178792

changeset:   155902:19a0dd9622a0
tag:         tip
user:        Tomas Hurka <thurka@netbeans.org>
date:        Mon Dec 21 13:07:24 2009 +0100
summary:     new profiler native binaries with the following changesets: fbbd58a28aa2 dc7f0d902bee 50e8150a97fe ee5a4dcb04e1
Comment 3 Quality Engineering 2009-12-22 23:42:59 UTC
Integrated into 'main-golden', will be available in build *200912230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ee5a4dcb04e1
User: Tomas Hurka <thurka@netbeans.org>
Log: bugfix #178771 and #178792
bugfix #178771 - cache loaded classes in several calls instead of one;
                 do not allow to redefine unchanged classes;
                 make sure that retransformIsRunning is initialized
bugfix #178792 - allow to cache classes when _ctable_size > 0;
                 cache classes, which was initialy loaded but not linked,
                 in ProfilerInterface.classLoadHook()
print error code returned by RetransformClasses()
Comment 4 sworisbreathing 2010-07-02 00:53:45 UTC
This issue appears to be a duplicate of http://netbeans.org/bugzilla/show_bug.cgi?id=150662


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo