Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178646 - UML plugin for NetBeans 6.8
UML plugin for NetBeans 6.8
Status: RESOLVED DUPLICATE of bug 171788
Product: uml
Classification: Unclassified
Component: Code Generation
6.x
PC Windows XP
: P1 with 16 votes (vote)
: TBD
Assigned To: issues@uml
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-15 04:25 UTC by 4bugzilla
Modified: 2013-01-05 23:01 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
patch for 6.8 - loading a diagram from xml file (1.44 KB, patch)
2010-02-27 11:10 UTC, slawekmikula
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description 4bugzilla 2009-12-15 04:25:45 UTC
I've downloaded NetBeans 6.8 "JavaFx" bundle and trying to add UML plugin.
But when I go to "Tools"->"Plugins"->"Available Plugins" there is no "UML" plugin.

Could you please check what is wrong?

Thanks,
Serhiy
Comment 1 Jiri Kovalsky 2009-12-15 06:03:20 UTC
This is unfortunately as designed right now. :-( We are really tight on resources and in order to stabilise core NetBeans IDE 6.8 features there was nobody left to focus on quality of UML. There are many serious issues like bug #171788 which didn't allow us to put the UML even on Beta UC.

Alexei, can you please comment on this? Do you plan to publish UML at least on Beta UC [1] anytime soon? Thanks!

[1] http://wiki.netbeans.org/NB68BetaModulesUC
Comment 2 Alexei Mokeev 2009-12-16 09:51:21 UTC
Thanks Jirka for rising this question. Right now we are evaluating plugins that has to be updated for 6.8, please be patient.
Comment 3 Jiri Kovalsky 2010-02-11 08:45:37 UTC
Any update on this Alexei? Thanks a lot!
Comment 4 Alexei Mokeev 2010-02-11 09:02:08 UTC
No update so far.
Comment 5 slawekmikula 2010-02-27 11:10:13 UTC
Created attachment 94594 [details]
patch for 6.8 - loading a diagram from xml file

For my observation there are two main issues with the UML plugin in 6.8. I'm using it with a basic form as only a diagraming (drawing) tool. I've not used code generation etc. The two main issues are:
- does not list model elements and diagram items in the project tree after loading the project. I've digged through the code but cannot find where the error is. the code seems just OK. The items are added to the arrays, the onExpand action is fired but threre is no visual apperance of the items. There is a situation, which fill the tree with data. When one adds a diagram of model element through context menu - one level of the model/diagram is painted. But the next onExpand level does not work (only when you add something to it). With this issue i'm a begginer in NB platform coding and could not get further with it. The examples and code from other plugins are much more easier to understand than the UML project loading code.
- does not load diagram on dblclick on the diagram element in the project tree. It is caued by closing xml parser before loading elements in it. In the attachement please find small patch, which enables this diagram loading. It's very hackish because it disables some part of code, which normally (?) should be uncommented - I hope this code was compiled in the original form for 6.7 and works thus it's a bit of hack.
Comment 6 Jiri Kovalsky 2010-03-01 04:07:34 UTC
Alexei, can you please ask somebody from your team to take a look at this patch? Is not there a better solution than avoiding closing of the XML parser in finally block?

Thanks for your patch Slawek and your evaluation Alexei!
Comment 7 Alexei Mokeev 2010-03-01 04:44:56 UTC
Slawek, thank you for the patch.
Jirka, unfortunately it's not possible to review the patch immediately.
Comment 8 slawekmikula 2010-03-21 16:04:39 UTC
May I have a question to NB Developers. I'll try to debug the first bug described by by (tree expanding). It would be nice, if someone can point me to the code in NB 6.8 core packages (platform) responsible for painting the project tree? I might dig it by myself, but it will be much faster when someone points me to the right direction. Thanks.
Comment 9 AngeloD 2010-03-23 21:24:17 UTC
Bug 171788 

http://netbeans.org/bugzilla/show_bug.cgi?id=171788

is related to this one.
Comment 10 slawekmikula 2010-03-25 11:49:14 UTC
Right now i'm testing 6.9 DEV "NetBeans IDE Dev (Build 201003250201)" and something is different. 

When doubleclick on the diagram in the tree (to open diagram) the exception shows up:

Caused by: java.lang.AssertionError at org.netbeans.modules.uml.drawingarea.UMLDiagramTopComponent.<init>(UMLDiagramTopComponent.java:258)
	at org.netbeans.modules.uml.drawingarea.UMLDiagramManager.showDiagram(UMLDiagramManager.java:511)
	at org.netbeans.modules.uml.drawingarea.UMLDiagramManager.openDiagram(UMLDiagramManager.java:135)
	at org.netbeans.modules.uml.ui.products.ad.projecttreedefaultengine.ADProjectTreeEngine.handleDoubleClick(ADProjectTreeEngine.java:3485)
	at org.netbeans.modules.uml.ui.products.ad.projecttreedefaultengine.ADProjectTreeEngine.onNodeDoubleClick(ADProjectTreeEngine.java:3426)
	at org.netbeans.modules.uml.ui.products.ad.projecttreedefaultengine.ADProjectTreeEngine$ProjectTreeListener.onDoubleClick(ADProjectTreeEngine.java:3742)


This is something new as in 6.8 the exception does not show up.

Something new is also with the expanding events. Still the same is with expanding objects (in model). The content does not show up. But when i add a new diagram (to refresh the tree) elements show up AND when i add something to the diagram (on the same level) the element DOES show on the tree. In 6.8 nothing happened in this situation.

Nonetheless i haven't found anything in the NB code for fixing this issue - i'm too unexperienced for this task. It would be great, if NB team fix this issue for 6.9 release - nothing new but make it works. Many people stick with this editor for documenting purposes.
Comment 11 slawekmikula 2010-05-25 14:01:31 UTC
Version: NetBeans IDE 6.9 Dev (Build 201005250001)

Problem still exists.
Comment 12 Marian Mirilovic 2011-11-19 07:55:25 UTC
Comment 10 -> uml
Comment 13 javydreamercsw 2011-11-19 17:13:36 UTC
The code is too outdated to find a fix right now. Since is not compatible with current platform there's too much to do that is easier to just rewrite it. See the new attempt to rewrite it: http://java.net/projects/eidos-uml
Comment 14 Sergey Petrov 2013-01-05 23:01:29 UTC
hack for diagram loading was pushed recently.
tried to look a bit at project tree issue, no success so far, have no much experience with project tree, but it's main one. close as duplicate. other part like update center publishing may be won't fix. not sure when will have time to look more, but can review/try any patch for 171788 is someone will suggest any.

*** This bug has been marked as a duplicate of bug 171788 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo