Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178517 - After converting a facelets snippet into a composite component, library is not found
After converting a facelets snippet into a composite component, library is no...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF Editor
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Marek Fukala
issues@javaee
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-11 15:57 UTC by dheffelfinger
Modified: 2010-01-27 15:13 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (92.09 KB, image/png)
2009-12-11 15:57 UTC, dheffelfinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dheffelfinger 2009-12-11 15:57:38 UTC
Created attachment 92450 [details]
Screenshot

Attempting to duplicate bug 178514 under Linux, was unsuccessful.

However, ran into a different bug.

After highlighting part of a Facelets page and selecting "Convert to Composite Component", the composite component was created successfully, and the following XML namespace was added to the page:

xmlns:ez="http://java.sun.com/jsf/composite/ezcomp

NetBeans underlines the above line with a squiggly red line.

Hovering over it reveals the following error:

"No library found for this namespace".
Comment 1 Marek Fukala 2009-12-14 04:58:00 UTC
reproducible, the jsf libraries cached is not refreshed after a new library is found during indexing. The workaround is to either restart netbeans or to modify and save the web.xml in the project.
Comment 2 Marek Fukala 2009-12-17 07:17:56 UTC
fixed in web-main#e102675d8397
Comment 3 Quality Engineering 2009-12-17 23:50:16 UTC
Integrated into 'main-golden', will be available in build *200912180200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e102675d8397
User: Marek Fukala <mfukala@netbeans.org>
Log: #178517 -  After converting a facelets snippet into a composite component, library is not found
Comment 4 Jindrich Sedek 2010-01-11 05:59:40 UTC
seems to be ok in trunk
Comment 5 pgebauer 2010-01-14 04:43:59 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/bc68c4c1d296
Comment 6 Michal Mocnak 2010-01-27 15:13:46 UTC
Verified in 68fixes branch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo