Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 178429 - [saas] drop to EE6 project should generate @WebServlet to servlets
[saas] drop to EE6 project should generate @WebServlet to servlets
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Manager
6.x
PC All
: P2 (vote)
: 6.x
Assigned To: Peter Liu
issues@webservices
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 07:57 UTC by Lukas Jungmann
Modified: 2010-01-27 03:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2009-12-10 07:57:59 UTC
-create a javaee6 webapp (w/o deployment descriptor - default behaviour)
-drop some saas service call into a jsp or servlet there
-run jsp or the servlet with the saas service call

=> browser shows HTTP 404

Problem is that because of missing web.xml no url mappings for servlets are defined

solutions:

1) create web.xml before doing a drop of saas service into webapp

2) add @javax.servlet.annotation.WebServlet(name="<servletName>", urlPatterns={"/<servletMapping>"}) to generated servlets
Comment 1 Milan Kuchtiak 2009-12-11 09:21:01 UTC
Fixed.

Details:
http://hg.netbeans.org/main/rev/0a6d64b4084
Comment 2 Quality Engineering 2009-12-11 20:54:32 UTC
Integrated into 'main-golden', will be available in build *200912111937* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0a6d64b4084e
User: mkuchtiak@netbeans.org
Log: #178429: generate @WebServlet annotation for Saas ServiceLogin and ServiceCallback
Comment 3 Lukas Jungmann 2010-01-14 03:37:20 UTC
still reproducible even after a fix - there's no @WebServlet being generated in:

Product Version: NetBeans IDE 6.8 (Build 200912041610)
Java: 1.6.0_18-ea; Java HotSpot(TM) Client VM 16.0-b10
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)
Userdir: C:\Users\lukas\.netbeans\6.8

Milan, can you re-check this, please?
thx
Comment 4 Lukas Jungmann 2010-01-14 03:45:05 UTC
whoops, that was 6.8 build... rechecking, my fault, sorry
Comment 5 Lukas Jungmann 2010-01-14 03:57:57 UTC
v. in:

Product Version: NetBeans IDE Dev (Build 201001140201)
Java: 1.6.0_18-ea; Java HotSpot(TM) Client VM 16.0-b10
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)
Userdir: C:\Users\lukas\.netbeans\dev
Comment 6 pgebauer 2010-01-14 13:16:55 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/d36f4ac222e7


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo