Bug 178404 - FXErrorAnnotator abuses EDT
FXErrorAnnotator abuses EDT
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: TBD
Assigned To: J Bachorik
issues@javafx
68patch1-verified
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 01:13 UTC by Martin Krauskopf
Modified: 2010-01-26 05:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
EDT-abused thread dump (3.82 KB, text/plain)
2009-12-10 01:13 UTC, Martin Krauskopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Krauskopf 2009-12-10 01:13:02 UTC
Created attachment 92371 [details]
EDT-abused thread dump

JavaFXSource#runUserActionTask should not be called from EDT. Cf. attachment or just run NetBeans (fresh trunk).

Not sure if you are the right person Jardo (guessing so from #2ab79fbcbd5d). Reassign if not, thanks.
Comment 1 J Bachorik 2009-12-10 03:06:34 UTC
fixed in http://hg.netbeans.org/javafx/rev/c0adef925c7a
Comment 2 rbalada 2010-01-21 05:31:52 UTC
Please verify this fix, so it can be included as part of fix for issue 179013
Comment 3 Alexandr Scherbatiy 2010-01-21 06:44:14 UTC
Unable to reproduce the issue.

Verified in NetBeans-JavaFX-Soma: #122  (Jan 21, 2010 12:00:49 AM)
Comment 4 rbalada 2010-01-21 06:59:38 UTC
The fix has been ported to release68_fixes branch as
http://hg.netbeans.org/javafx/rev/852d9e25c7ef

(changeset shared with #179013 and #178838)
Comment 5 Alexandr Scherbatiy 2010-01-26 05:09:47 UTC
Verified in NB 6.8 patch1 2010-01-25_21-27-59


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo