Bug 178225 - Renaming overridden attribute shows dialog with class name
Renaming overridden attribute shows dialog with class name
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Unsupported
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: J Bachorik
issues@javafx
http://javafx-jira.kenai.com/browse/J...
68patch1-verified
:
Depends on:
Blocks: 173077
  Show dependency treegraph
 
Reported: 2009-12-07 05:01 UTC by Alexandr Scherbatiy
Modified: 2010-01-28 03:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2009-12-07 05:01:26 UTC
JavaFX 1.3
Build  #58 Dec 7, 2009 12:00:35 AM

  Product Version         = NetBeans IDE 6.8 (Build 200912041610) (#ec9be6a6486c)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02; Sun Microsystems Inc.

Steps to reproduce:

- Copy the code to the editor:
-------------------------------------------
class A{
    public var name:String = "A";
}

class B extends A{
    override var name = "B";
}
-------------------------------------------

- Refactor->Rename the 'name' attribute in the B class

The 'Rename Class B' dialog is shown
Comment 1 J Bachorik 2009-12-07 08:57:37 UTC
Caused by a bug in compiler
Comment 2 J Bachorik 2009-12-10 03:01:45 UTC
Worked around in http://hg.netbeans.org/javafx/rev/31392448427c
Comment 3 Alexandr Scherbatiy 2009-12-14 02:42:57 UTC
verified in NetBeans-JavaFX-Soma:  #65
Comment 4 rbalada 2010-01-27 08:35:12 UTC
Workaround ported into release68_fixes branch as
http://hg.netbeans.org/javafx/rev/8c210a816820 resp. not reproducible on release68_fixes branch anymore
Comment 5 Alexandr Scherbatiy 2010-01-28 03:38:02 UTC
Verified in NB 6.8 Patch1 2010-01-28_00-36-51


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo