Bug 178137 - [68cat] GoToType took 33033 ms.
[68cat] GoToType took 33033 ms.
Status: RESOLVED DUPLICATE of bug 177274
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks: 177274
  Show dependency treegraph
 
Reported: 2009-12-04 05:32 UTC by Exceptions Reporter
Modified: 2009-12-12 07:46 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-12-04 05:33 UTC, Exceptions Reporter
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 07:38 UTC, misterm
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 07:40 UTC, misterm
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 07:40 UTC, misterm
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 07:41 UTC, misterm
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 08:46 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 08:47 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 08:49 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 08:50 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 09:10 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 09:11 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 09:13 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-04 09:14 UTC, Vladimir Voskresensky
Details
nps snapshot (256.00 KB, application/nps)
2009-12-09 06:08 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2009-12-04 05:32:55 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-4441-on-091202)
VM: Java HotSpot(TM) Server VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows XP, 5.1, x86
Maximum slowness yet reported was 33033 ms, average is 24455
Comment 1 Exceptions Reporter 2009-12-04 05:33:00 UTC
Created attachment 92101 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2009-12-04 06:09:01 UTC
The previous attachment shows >10s in lucene. Five calls to getDeclaredType multiplies to hundreds of calls to validate index. There is also 9s wasted in JavaScript.
Comment 3 Alexei Mokeev 2009-12-04 06:15:03 UTC
Isn't this the same as
https://netbeans.org/bugzilla/show_bug.cgi?id=177274
(Go to type is very slow)
Comment 4 misterm 2009-12-04 07:38:58 UTC
Created attachment 92114 [details]
nps snapshot
Comment 5 misterm 2009-12-04 07:40:00 UTC
Created attachment 92115 [details]
nps snapshot
Comment 6 misterm 2009-12-04 07:40:59 UTC
Created attachment 92116 [details]
nps snapshot
Comment 7 misterm 2009-12-04 07:41:59 UTC
Created attachment 92117 [details]
nps snapshot
Comment 8 Vladimir Voskresensky 2009-12-04 08:46:59 UTC
Created attachment 92122 [details]
nps snapshot
Comment 9 Vladimir Voskresensky 2009-12-04 08:47:59 UTC
Created attachment 92123 [details]
nps snapshot
Comment 10 Vladimir Voskresensky 2009-12-04 08:49:00 UTC
Created attachment 92124 [details]
nps snapshot
Comment 11 Vladimir Voskresensky 2009-12-04 08:50:00 UTC
Created attachment 92125 [details]
nps snapshot
Comment 12 Alexei Mokeev 2009-12-04 08:57:19 UTC
->parsing and indexing
Comment 13 Vladimir Voskresensky 2009-12-04 09:10:59 UTC
Created attachment 92126 [details]
nps snapshot
Comment 14 Vladimir Voskresensky 2009-12-04 09:11:59 UTC
Created attachment 92127 [details]
nps snapshot
Comment 15 Vladimir Voskresensky 2009-12-04 09:13:00 UTC
Created attachment 92128 [details]
nps snapshot
Comment 16 Vladimir Voskresensky 2009-12-04 09:14:00 UTC
Created attachment 92129 [details]
nps snapshot
Comment 17 Vitezslav Stejskal 2009-12-07 09:35:43 UTC
http://hg.netbeans.org/jet-main/rev/838a00a6439c
Comment 18 Egor Ushakov 2009-12-09 06:08:30 UTC
Created attachment 92334 [details]
nps snapshot
Comment 19 Egor Ushakov 2009-12-09 06:13:00 UTC
I've just submitted 61s delay!!! With no background activity! On Dev build
20091207, please do something with that! It is impossible to develop like that!
Raising priority to P2.
Comment 20 Quality Engineering 2009-12-10 02:32:49 UTC
Integrated into 'main-golden', will be available in build *200912100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/838a00a6439c
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #178137: keep the URL so that it does not have to be computed over again and again
Comment 21 Tomas Zezula 2009-12-12 07:46:59 UTC
It's a duplicate of the umbrella issue.
>Five calls to getDeclaredType multiplies to hundreds of calls to validate index.
Nothing new Jardo, there was already an subtask to change it (#177462).
The issue #177462 is now fixed.

*** This bug has been marked as a duplicate of bug 177274 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo