Bug 178093 - Display in the window with open file list (CTRL+TAB) path of the selected file.
Display in the window with open file list (CTRL+TAB) path of the selected file.
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 with 1 vote (vote)
: 7.2
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks: 178090
  Show dependency treegraph
 
Reported: 2009-12-03 10:03 UTC by Petr Pisl
Modified: 2012-04-16 22:55 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screenshot of the IDE, when the popup window with the opened files is open. (118.91 KB, image/png)
2009-12-03 10:07 UTC, Petr Pisl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2009-12-03 10:03:38 UTC
This issue is motivated by the case mentioned in the issue #178090. 

When you press shortcut CTRL+TAB, then a popup window is displayed with the list of opened files. Keeping CTRL and press TAB you can select the file (tab in editor) that will be focused. The problem is that when you have opened a few files with the same name, then you can not find the file that you want to display. 

There is displayed the path of selected file in the status bar of the IDE (see screentshot), but it's almost useless. User is watching the popup window with the opened files and is impossible to look at the status bar and the popup window at the same time. The path of the selected file has to be a part of the popup window. Probably displayed as last line, but visually separated (JIdea has this approach).
Comment 1 Petr Pisl 2009-12-03 10:07:06 UTC
Created attachment 92057 [details]
Screenshot of the IDE, when the popup window with the opened files is open.
Comment 2 Jesse Glick 2009-12-04 08:56:06 UTC
Could simply display the full path *instead of* the usual tab name.
Comment 3 Stanislav Aubrecht 2012-04-16 13:45:47 UTC
Already available in dev builds.
Comment 4 Jesse Glick 2012-04-16 22:55:17 UTC
(Or DUPLICATE.)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo