Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 177864 - Support for persistenceID attribute in CustomFolds
Support for persistenceID attribute in CustomFolds
Status: RESOLVED DUPLICATE of bug 188573
Product: editor
Classification: Unclassified
Component: Code folding
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: Svata Dedic
issues@editor
:
Depends on:
Blocks: 188573
  Show dependency treegraph
 
Reported: 2009-11-30 09:22 UTC by David Kaspar
Modified: 2016-07-13 12:23 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kaspar 2009-11-30 09:22:42 UTC
Currently Custom Folds does not have any persistence ID. Also the Custom-Fold recognition is started asynchronously on a change in a document.

Therefore it is not possible to keep collapse/expand state of folds that are regenerated in a document e.g. MultiDataObject with a text and binary file when some parts of text is re-generated from the binary file.

If a custom-fold tag "<editor-fold ...>" would be having a "persistenceID" attribute, then the CustomFoldManager/FoldHierarchy would be able to store the collapse/expand state inside persistently (e.g. through the Document life-cycle). The custom-fold when will automatically expand/collapse itself when recognized in a text.
Comment 1 Svata Dedic 2012-02-10 16:43:07 UTC
Connecting with 188573 - persistence for folds.
Comment 2 Martin Balin 2016-07-07 07:30:05 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss
Comment 3 Svata Dedic 2016-07-13 12:23:30 UTC
A subset of persistent folding requested by issue #188573

*** This bug has been marked as a duplicate of bug 188573 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo