Bug 177051 - ClassNotFoundException appears when create new j2se project
ClassNotFoundException appears when create new j2se project
Status: VERIFIED DUPLICATE of bug 177061
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
PC All
: P1 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
: ERGONOMICS
: 176885 177170 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-18 01:55 UTC by Jaromir Uhrik
Modified: 2010-05-24 13:07 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log attached (77.57 KB, application/octet-stream)
2009-11-18 02:41 UTC, Jaromir Uhrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2009-11-18 01:55:10 UTC
Steps to reproduce:
-start ide with clear userdir
-create new j2se project
-->> exception appears shortly
Comment 1 Jaromir Uhrik 2009-11-18 02:41:41 UTC
Created attachment 91224 [details]
messages.log attached
Comment 2 Jesse Glick 2009-11-18 10:52:39 UTC
Looks like an ergonomics issue - j2seproject is just being turned on.
Comment 3 Petr Nejedly 2009-11-18 12:16:39 UTC
This doesn't look like ergonomics issue, but maybe a configuration problem.
The exception probably occurs when you have glassfish.common module but no glassfish.javaee
Glassfish.common has a layer entry calling org.netbeans.modules.glassfish.javaee.Hk2DeploymentFactory.createPrelude (from the glassfish.javaee module).
Now, I have an installation containing glasfish.common but no glassfish.javaee, as I have opted not to install glassfish during installation.
And I see no dependency that would prevented such a situation and specifically in the log here, glassfish.common is enabled and glassfish.javaee is not mentioned at all.
Comment 4 Petr Nejedly 2009-11-19 07:03:09 UTC
This exception will likely pop up for many users after the installation of the full IDE, upon creating/opening their first java project. This makes very bad OOB experience.
Comment 5 Sergey Petrov 2009-11-19 08:16:08 UTC
*** Bug 176885 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2009-11-19 09:19:19 UTC
*** Bug 177170 has been marked as a duplicate of this bug. ***
Comment 7 Vince Kraemer 2009-11-19 09:44:37 UTC
this issue has the same messages as the exception associated with bug 177061.

closing as a dup.

*** This bug has been marked as a duplicate of bug 177061 ***
Comment 8 Jaromir Uhrik 2010-05-24 13:07:49 UTC
Duplicate, marking Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo