Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176953 - Web application deploy to the wrong server
Web application deploy to the wrong server
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
PC Windows XP x64
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 16:05 UTC by davisn
Modified: 2010-01-20 06:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log file (259.52 KB, text/plain)
2009-11-16 16:06 UTC, davisn
Details
sdk6-b73 server.log file (10.13 KB, text/plain)
2009-11-16 16:09 UTC, davisn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davisn 2009-11-16 16:05:17 UTC
If I have 2 V3 server with the same port 8080 registered in the IDE, the web application seems always deploy the current running server.

Steps To Reproduce:
1. Install NB 6.8 nightly (11/16/2009) on winXP, jdk1.6.0_16
2. Install nightly SDK b73 build from http://javaweb.sfbay/java/re/glassfish/v3/nightly/bundles/java_ee_sdk-6-b29-11_13_2009-windows.exe
3. Start the IDE -> register the sdk6-73 server
4. From the IDE, start the sdk6-b73 server
5. From the ..glassfish\samples\bp-project directory, edit build.properties file and point javaee.home to the location of the sdk6-73 installed server.
6. Open web/container/customvale-war project -> change the runtime to sdk6-b73 server -> run the project
7. Open web/jsf/basic-ajax project -> leave the runtime server default as "GlassFish v3 Domain" -> run the baisc-ajax project
BUG:
  The basic-ajax project was deployed to the sdk6-b73 server.
Comment 1 davisn 2009-11-16 16:06:05 UTC
Created attachment 91135 [details]
IDE log file
Comment 2 davisn 2009-11-16 16:09:56 UTC
Created attachment 91136 [details]
sdk6-b73 server.log file
Comment 3 Vince Kraemer 2009-11-16 16:17:49 UTC
ant output from the Deploy or Run that went to the wrong target?
Comment 4 davisn 2009-11-16 19:14:50 UTC
All the run operation was selected from the Netbean "run" target IDE menu.
Comment 5 Vince Kraemer 2009-11-16 20:22:45 UTC
OK.  So, please attach the output generated by ant.
Comment 6 Vince Kraemer 2009-11-17 11:36:00 UTC
this is not a stopper for 6.8, though I do want to fix it as part of an early patch.
Comment 7 davisn 2009-11-17 12:27:24 UTC
This problem seems do not relate with the SDK samples since I can reproduce it without using the SDK sample projects. Below is the steps without using the SDK samples.

-From NB IDE, register a donwload v3 server (use the default configuration)
-Create a web app and set the runtime server to the default "GlassFish v3 Domain"
-From the IDE -> web app project node, select to run the project
-From the Servers node -> GlassFish v3 Domain, select to undeploy the web app
-Change the web app runtime to the download server
-From the IDE -> web app project node, select to run the project
Note:
  The project is deployed to the GlassFish v3 Domain regardless of different runtime server configuration
Comment 8 Vince Kraemer 2009-12-08 12:57:01 UTC
http://hg.netbeans.org/web-main/rev/52c083f1ae5a
Comment 9 Vince Kraemer 2009-12-09 18:06:17 UTC
one additional fix... http://hg.netbeans.org/web-main/rev/501c959ac94e
Comment 10 Quality Engineering 2009-12-10 02:32:31 UTC
Integrated into 'main-golden', will be available in build *200912100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/52c083f1ae5a
User: Vince Kraemer <vkraemer@netbeans.org>
Log: #176953: web app deploys to wrong server
Comment 11 Quality Engineering 2009-12-10 15:00:47 UTC
Integrated into 'main-golden', will be available in build *200912101400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/501c959ac94e
User: Vince Kraemer <vkraemer@netbeans.org>
Log: #176953: web app deploys to wrong server...
one more additional change necessary
[exposed by testing remote deployment]
Comment 12 pgebauer 2010-01-19 07:38:56 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/f1b0eb523192


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo