Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176929 - When renaming a method parameter, rename in comments should be limited to the Javadoc for the method.
When renaming a method parameter, rename in comments should be limited to the...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
: NETFIX
: 179696 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 10:44 UTC by Marian Petras
Modified: 2010-11-11 15:48 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Limiting method parameter rename to the scope of the method (7.59 KB, patch)
2010-04-17 18:38 UTC, kapitarg
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2009-11-16 10:44:46 UTC
When a method parameter is being renamed using action Refactor > Rename... and the user choses to rename the method parameter also in comments, the scope of renaming should be limited only to the Javadoc of the method.
--
JDK 6u18-b04, 64-bit, server VM
Linux (Debian Lenny), 64-bit, Intel CPU
Comment 1 Jiri Kovalsky 2010-04-08 11:20:20 UTC
Issue added to NetFIX Pool [1]. Module owner please speak up if you disagree.

[1] http://wiki.netbeans.org/NetFIXIssues
Comment 2 kapitarg 2010-04-17 18:38:31 UTC
Created attachment 97565 [details]
Limiting method parameter rename to the scope of the method

IMHO limiting the scope of rename only to the javadoc, is too restrictive. At least I would find reasonable to add a comment referring to the parameter anywhere, where the parameter could be used. And in that case, those references in the comments should be renamed as well.

So in the patch, I limited the scope of the rename only to comments before the method, and to comments within the method body.
Comment 3 Jiri Kovalsky 2010-04-19 14:42:26 UTC
Tomasi, what do you think about this patch? Can you please integrate it if you don't have any comments? Thanks!
Comment 4 Tomas Zezula 2010-04-20 08:23:19 UTC
I will look at it tonight or tomorrow. Sorry I am very busy now.
Comment 5 Tomas Zezula 2010-04-22 12:58:19 UTC
The patch seems fine to me. Thanks for it and feel free to integrate.
Comment 6 Jiri Kovalsky 2010-04-22 13:08:08 UTC
Tomasi, Gabor does not have a push access to our Hg repository. Could you please integrate the patch on his behalf? Many thanks!
Comment 7 Tomas Zezula 2010-04-22 13:33:09 UTC
OK, I will do it.
Comment 8 Tomas Zezula 2010-04-23 08:21:09 UTC
Integrated into jet-main 76a8012d1857
Thanks for the patch!
Comment 9 Jiri Kovalsky 2010-04-23 09:13:12 UTC
Wonderful, thanks Tomasi for your review & integration and special thanks to Gabor for your patch!
Comment 10 Quality Engineering 2010-04-24 05:20:22 UTC
Integrated into 'main-golden', will be available in build *201004240200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/76a8012d1857
User: Tomas Zezula <tzezula@netbeans.org>
Log: #176929:When renaming a method parameter, rename in comments should be limited to the Javadoc for the method. - integrating kapitarg's patch.
Comment 11 Jan Becicka 2010-11-11 15:48:49 UTC
*** Bug 179696 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo