Bug 176826 - [68cat] Invoking fix-imports took 9333 ms.
[68cat] Invoking fix-imports took 9333 ms.
Status: RESOLVED DUPLICATE of bug 171183
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-13 13:46 UTC by greggwon
Modified: 2009-11-16 08:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-13 13:46 UTC, greggwon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description greggwon 2009-11-13 13:46:34 UTC
Build: NetBeans IDE Dev (Build 200911091156)
VM: Java HotSpot(TM) Client VM, 14.0-b05, Java(TM) SE Runtime Environment, 1.7.0-ea-b38
OS: Windows Vista, 6.0, x86

User Comments:
stefan79: Parameter-Guessing on a Method with 3 parameters.

stefan79: Fix Imports on a class with 8200 lines

stefan79: Parameter-Guessing

stefan79: Parameter-Guessing.

GUEST: fixing imports on a small java class with ~120 lines..

stefan79: Parameter Guessing.

greggwon: Finished editing text and was trying to use fix Imports.

This is one of those cases where parsing is running in the background, expanding the RSS by a large number of pages and the use of the EDT thread is causing the application pause for paging to block the EDT and disabling GUI events etc.

stefan79: Parameter-Guessing.

stefan79: Parameter guessing.


Maximum slowness yet reported was 12516 ms, average is 6107
Comment 1 greggwon 2009-11-13 13:46:39 UTC
Created attachment 91035 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-11-13 13:46:47 UTC
This issue already has 11 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=160527
Comment 3 Dusan Balek 2009-11-16 08:44:15 UTC
The case with fix import is already fixed. The case with CompletionImpl.substitute Text() is already reported as #171183. Thanks.

*** This bug has been marked as a duplicate of bug 171183 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo