Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176798 - [68cat] Stack Overflow when running application via JWS
[68cat] Stack Overflow when running application via JWS
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Module System
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
68patch1-verified
: SIMPLEFIX
: 178554 179152 179725 (view as bug list)
Depends on:
Blocks: 20838
  Show dependency treegraph
 
Reported: 2009-11-13 07:41 UTC by javydreamercsw
Modified: 2010-11-11 19:44 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log file (91.61 KB, text/plain)
2009-11-13 07:41 UTC, javydreamercsw
Details
Logs (91.47 KB, text/plain)
2009-12-10 15:35 UTC, javydreamercsw
Details
Log (91.17 KB, text/plain)
2009-12-11 16:47 UTC, javydreamercsw
Details
CMAIS module layer (2.85 KB, text/xml)
2009-12-11 16:58 UTC, javydreamercsw
Details
HIMS module layer (8.80 KB, text/xml)
2009-12-11 16:58 UTC, javydreamercsw
Details
PCEIS module layer (9.77 KB, text/xml)
2009-12-11 16:59 UTC, javydreamercsw
Details
The NBM with fix for testing. (256.41 KB, application/octet-stream)
2010-01-26 09:32 UTC, pgebauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2009-11-13 07:41:56 UTC
Created attachment 91003 [details]
log file

Build 200911091156

Trying to start an application via jws creates a Stack Overflow. The application worked just fine until built from a recent build of the IDE. See attached file.

Might be related to https://netbeans.org/bugzilla/show_bug.cgi?id=153265
Comment 1 javydreamercsw 2009-11-17 08:54:17 UTC
I suggest making it atleast P2 since it renders applications unusable via jws
Comment 2 dlipin 2009-11-17 09:22:39 UTC
duplicate of Issue 175853 ?
Comment 3 javydreamercsw 2009-11-17 16:42:38 UTC
Not related.
Comment 4 Jesse Glick 2009-11-18 10:00:00 UTC
Reproducible. Very similar to issue #175853, will probably need similar fix.
Comment 5 Jesse Glick 2009-11-18 10:28:04 UTC
core-main #30fb5b4c0279
Comment 6 Quality Engineering 2009-11-19 03:29:50 UTC
Integrated into 'main-golden', will be available in build *200911190201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/30fb5b4c0279
User: Jesse Glick <jglick@netbeans.org>
Log: #176798: stack overflow fix in RecognizeInstanceFiles needed to be generalized to work in JNLP mode.
Comment 7 javydreamercsw 2009-12-10 15:35:35 UTC
Created attachment 92397 [details]
Logs

I got the same error in Build 200912100200. Sorry I noticed after releasing 6.8 FCS. I'll retry on 6.8 Final and update this bug with my results.
Comment 8 javydreamercsw 2009-12-10 15:36:26 UTC
See attachment comment.
Comment 9 javydreamercsw 2009-12-10 16:22:16 UTC
Sadly it also happens in 6.8 FCS as I expected.
Comment 10 Jesse Glick 2009-12-10 17:26:02 UTC
I can't tell for sure without a test case to reproduce, but I'm guessing it's hitting an nbresloc URL in one of your layers, rather than an nbres URL.

Need to generalize again: core-main #6a39244a4fb5

Let me know if this seems to fix it (after the patch makes it into the next daily build), and if so this can go into 6.8.1.
Comment 11 javydreamercsw 2009-12-11 16:47:50 UTC
Created attachment 92451 [details]
Log

Sorry to give feedback so late, was a crazy day at work. Anyways it still happens. I'll try to load the project as well since you mentioned something about my layer files.
Comment 12 javydreamercsw 2009-12-11 16:48:09 UTC
Still happening.
Comment 13 javydreamercsw 2009-12-11 16:57:03 UTC
Project is way too big to attach. I'll attach the layer files. Looks like that's what you want to see.
Comment 14 javydreamercsw 2009-12-11 16:58:01 UTC
Created attachment 92452 [details]
CMAIS module layer
Comment 15 javydreamercsw 2009-12-11 16:58:36 UTC
Created attachment 92453 [details]
HIMS module layer
Comment 16 javydreamercsw 2009-12-11 16:59:15 UTC
Created attachment 92454 [details]
PCEIS module layer
Comment 17 Quality Engineering 2009-12-11 20:53:55 UTC
Integrated into 'main-golden', will be available in build *200912111937* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6a39244a4fb5
User: Jesse Glick <jglick@netbeans.org>
Log: Yet another attempt to fix stack overflow #176798.
Comment 18 javydreamercsw 2009-12-13 12:25:55 UTC
This is fixed in build 200912130200. Great work!
Comment 19 Jesse Glick 2010-01-12 08:42:54 UTC
(In reply to comment #18)
> This is fixed in build 200912130200.

Noting, thank you.
Comment 20 pgebauer 2010-01-14 01:51:21 UTC
The fix has been ported into the release68_fixes repository.
http://hg.netbeans.org/release68_fixes/rev/1d17f23fb222
Comment 21 Jesse Glick 2010-01-18 10:29:19 UTC
*** Bug 179152 has been marked as a duplicate of this bug. ***
Comment 22 Jesse Glick 2010-01-20 19:33:12 UTC
*** Bug 179725 has been marked as a duplicate of this bug. ***
Comment 23 Tomas Danek 2010-01-26 05:53:46 UTC
any reproducible testcase to be able to verify in 68 patch 1? Thanks in advance.
Comment 24 Jesse Glick 2010-01-26 09:03:01 UTC
javydreamercsw is the only person I know was able to reproduce. Are there dev builds from release68_fixes he could test against?
Comment 25 pgebauer 2010-01-26 09:32:39 UTC
Created attachment 93567 [details]
The NBM with fix for testing.

Could javydreamercsw test the NBM from the attachment?
Please, use Tools -> Plugins -> Downloaded Tab -> Add Plugins to NBM installation.
Comment 26 javydreamercsw 2010-01-26 18:30:32 UTC
Hopefully tomorrow I can give it a try.
Comment 27 javydreamercsw 2010-01-27 07:22:51 UTC
I get the following message:

Plugin "Utilities API" is already installed. 

I couldn't find it to uninstall and install new one. Maybe forgot to increase the version?
Comment 28 pgebauer 2010-01-27 07:57:02 UTC
The attached NBM has spec. version 7.31.2.1. The org.openide.util module in the official NetBeans IDE 6.8 has spec. version 7.31.1.1. Please, check your version of org.openide.util before update. I have tested the update of org.openide.util from 7.31.1.1 to 7.31.2.1 via the Downloaded tab on the vanilla IDE and everything worked smoothly.
Comment 29 javydreamercsw 2010-01-27 13:21:01 UTC
I tried on Netbeans with latest Dev. Build. Should I try with 6.8? If so, is there a way to go back (unistall it). 6.8 is used for development and I shouldn't update it like that unless I can get it back to current state.
Comment 30 pgebauer 2010-01-28 02:25:09 UTC
>Should I try with 6.8?
Yes, the NBM is for NetBeans IDE 6.8.

> If so, is there a way to go back (unistall it).
Please, backup your IDE install directory, install and check the attached NBM, restore the IDE from the backup thereafter.
Comment 31 javydreamercsw 2010-01-28 08:03:26 UTC
Still didn't work. I have NB + the latest updates (50+ updates that were available not long ago). I had to make a new install in a different dir to try it out. That said the version is not valid anyways for a NB + latest updates available via Update Center.

Sadly my project dependencies are already beyond the ones in vanilla NB 6.8. I tried to make it work but it needs a huge amount of changes to even attempt a conpile that are not worth the try (playing with NB xml config files is too risky IMO)
Comment 32 pgebauer 2010-01-28 10:47:40 UTC
>I have NB + the latest updates (50+ updates that were available not long ago).
I'm sorry but I don't understand what 50+ updates you mean. The NetBeans team hasn't published any update for the NetBeans IDE 6.8. Sounds like you have updated your IDE by something what isn't intended for the IDE 6.8.

Anyway, could you please do following steps:
1. Backup your NETBEANS_INSTALL_DIR (just rename it)
2. Backup your NETBEANS_HOME_DIR (just rename it)
3. Download the NetBenas IDE 6.8 from http://netbeans.org/downloads/index.html and install it
4. Install the attached NBM via Tools -> Plugins -> Downloaded Tab -> Add Plugins
5. Test whether the NBM fix the issue #176798
6. Delete newly created NETBEANS_INSTALL_DIR and NETBEANS_HOME_DIR
7. Restore back NETBEANS_INSTALL_DIR and NETBEANS_HOME_DIR from step 1. and 2.

I believe that it will work.
Comment 33 javydreamercsw 2010-01-28 11:54:08 UTC
That's weird because I remember seeing the message from the IDE about the new updates available (were initially 2 that then turned to 50+ after the restart)

Any ways I'll do as you say and give it a try. Also I'll check if I see those updates pop up again.
Comment 34 javydreamercsw 2010-01-28 12:15:45 UTC
I'm glad to agree that the issue is fixed! I had to clean the project of wrong version numbers (somehow I got mixed the dev stuff with released stuff). I'm cleaning that now.
Comment 35 pgebauer 2010-01-28 14:26:11 UTC
That's great! Thank you for your help.
I have marked the issue as 68patch1-verified.
Comment 36 Jesse Glick 2010-04-07 16:53:43 UTC
*** Bug 178554 has been marked as a duplicate of this bug. ***
Comment 37 Jesse Glick 2010-11-11 19:44:12 UTC
*** Bug 191868 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo