Bug 176637 - Debugger stops when breakpoints are set and path to file contains spaces
Debugger stops when breakpoints are set and path to file contains spaces
Status: CLOSED WONTFIX
Product: python
Classification: Unclassified
Component: Debugger
6.x
PC All
: P3 (vote)
: TBD
Assigned To: Lou Dasaro
issues@python
: SPACE_IN_PATH
: 179267 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-12 02:45 UTC by quamrana
Modified: 2017-06-23 08:06 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quamrana 2009-11-12 02:45:00 UTC
If the debugger is started when breakpoints are already set, or if debugging has started with no breakpoints and the first breakpoint is created, and the path of the file in question has spaces in it the debugger session ends.

I have tracked this down to jpydaemon.py line 1447 in parseSubCommand in JPyDbg where it splits out the 'BP+' parameters which it is expecting to be file and line and 'temp'?, space separated.  Perhaps whatever is sending the parameters should put quotes around the filename.

NetBeans IDE 6.7.1 (Build 200907230233)
Comment 1 Lou Dasaro 2015-11-08 03:14:10 UTC
*** Bug 179267 has been marked as a duplicate of this bug. ***
Comment 2 Jenselme 2017-06-22 20:15:37 UTC
Should be solved with the new debugger when we add it. Closing this since there is no point into importing it elsewhere.
Comment 3 Jiri Kovalsky 2017-06-23 08:06:00 UTC
Thanks for your evaluation Julien. Reporter, if you think your issue is still valid and needs to be addressed, don't hesitate to reopen it with additional information. Closing for now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo