Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 176606 - Alt+Tab does not remove menu Alt state when returning to editor
Alt+Tab does not remove menu Alt state when returning to editor
Status: RESOLVED DUPLICATE of bug 73960
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 15:52 UTC by djsipe
Modified: 2009-11-12 02:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description djsipe 2009-11-11 15:52:42 UTC
I'm using the PHP flavor of NetBeans.

Whenever I press Alt+Tab in Windows to switch to another application and then Alt+Tab back to NetBeans, the top menu is in focus..meaning I can press "F" to open the File menu and so on.

I can only imagine this is because the initial Alt keystroke I enter when pressing Alt+Tab is not getting reset when I return to the application.

This bug may seem minor, but it is a huge pain when you have to copy and paste text from another file into the editor.  It forces you to press Alt (or Esc) upon returning to the app so the cursor in the editor appears again and you can paste your text.
Comment 1 Jiri Prox 2009-11-12 02:42:50 UTC
I agree, this is very annoying, but unfortunately this is problem on swing side, we cannot do anything in Netbeans with it. See bug 73960

*** This bug has been marked as a duplicate of bug 73960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo