Bug 17660 - LookNode does not have equals method.
LookNode does not have equals method.
Status: VERIFIED DUPLICATE of bug 29192
Product: contrib
Classification: Unclassified
Component: Looks
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: Petr Hrebejk
issues@contrib
:
Depends on:
Blocks: 16186
  Show dependency treegraph
 
Reported: 2001-11-14 13:45 UTC by _ lkramolis
Modified: 2008-11-18 11:37 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch to fix this bug. (1.11 KB, patch)
2001-11-14 13:47 UTC, _ lkramolis
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description _ lkramolis 2001-11-14 13:45:45 UTC
LookNode does not have equals method, which will compare parameter to represente
Object. This behaviour is required by org.openide.nodes.Index --
Move[Up|Down]Action check if current node is child of its parent, and method
equals is used.

Class org.openide.node.FilterNode implements same requirement.
Comment 1 _ lkramolis 2001-11-14 13:47:10 UTC
Created attachment 3407 [details]
Patch to fix this bug.
Comment 2 Petr Hrebejk 2001-11-14 14:32:07 UTC
Changing the priority to P3. Notice that the Looks are experimental API.

I looked at the diff and I kind of don't like comparing Node to a 
represented object and saying they are equal. I'll investigate the 
actions and try to make LookNode with them as soon as I have time.
Comment 3 Petr Hrebejk 2001-11-20 15:03:49 UTC
OK, after discussion with Libor we agreed that this bug isn't in 
the LookNode but rather in the NodeProxyLook which has to provide
some special Index cookie which delegates to the IndexCookie of the
original Node and handles the comparison of nodes correctly. 

If XML module needs to fix it quickly they can try to put such a 
delegating IndexCookie into their's anccestor of NodeProxyLook. Should
this work well, we could move the implementation into Looks package.
Comment 4 Jan Chalupa 2001-11-27 15:30:21 UTC
Target milestone -> 3.3.1.
Comment 5 Petr Hrebejk 2002-06-24 11:12:25 UTC
Moving Looks issues to dev 4.0
Comment 6 Marian Mirilovic 2003-01-29 12:54:54 UTC
added keyword PROJECTS, because we need to distinguish 
issues against NB4.0 and S1Sx.y
Comment 7 Jesse Glick 2003-03-19 17:51:51 UTC
IMHO this should be considered duplicate of issue #29192 - it is not
LookNode which is broken, it is the design of the Index cookie.
Comment 8 _ pkuzel 2003-03-20 11:49:55 UTC

*** This issue has been marked as a duplicate of 29192 ***
Comment 9 Marian Mirilovic 2003-07-21 16:18:18 UTC
verified - it's duplicate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo