Bug 176568 - [69cat] [68cat] AWT thread blocked for 4064 ms.
[69cat] [68cat] AWT thread blocked for 4064 ms.
Status: RESOLVED DUPLICATE of bug 171183
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 09:57 UTC by Alexey Vladykin
Modified: 2012-04-23 14:28 UTC (History)
26 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (256.00 KB, application/nps)
2009-11-11 09:57 UTC, Alexey Vladykin
Details
nps snapshot (256.00 KB, application/nps)
2010-01-05 02:16 UTC, meowman
Details
nps snapshot (256.00 KB, application/nps)
2010-01-05 03:17 UTC, meowman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Vladykin 2009-11-11 09:57:51 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910212001)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Linux, 2.6.30-gentoo-r5, amd64

User Comments:
GUEST: Displaying auto completion

stefan79: At a string - Variable, I type "ends" and then Ctrl-space. Then I confirmed "endsWith". Then I had to wait 9 seconds.

alexey_vladykin: Pressed enter on an item in the completion popup

GUEST: Pressed Enter on a selected code completion hint.

jglick: Typing in editor.

jtulach: I pressed enter in code completion of a method call. 4.5s!?


Maximum slowness yet reported was 9516 ms, average is 5243
Comment 1 Alexey Vladykin 2009-11-11 09:57:57 UTC
Created attachment 90831 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-11-11 09:58:03 UTC
This issue already has 9 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=156707
Comment 3 Exceptions Reporter 2009-11-13 12:34:35 UTC
This issue already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=156707
Comment 4 Exceptions Reporter 2009-11-16 08:01:02 UTC
This issue already has 11 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=156707
Comment 5 Max Sauer 2009-12-07 06:05:45 UTC
Dusane, please have a look. Some of the reports seem to be similar to issue 177779.
Comment 6 meowman 2010-01-05 02:16:00 UTC
Created attachment 93068 [details]
nps snapshot

pressed CTRL + space then ENTER to select a suggested variable name in a Java standard project class file
Comment 7 meowman 2010-01-05 03:17:02 UTC
Created attachment 93070 [details]
nps snapshot

consistently happens when i attempt to press enter for a suggested completion of map method name in a particular class that implements map, but delegates to internal map instance
Comment 8 _ tboudreau 2010-01-16 13:20:21 UTC
The problem appears to generally be when code-completion is searching for a
variable in-scope to put into the completion of a method that takes an argument
of a parameterized type.
Comment 9 _ tboudreau 2010-01-16 13:20:58 UTC
method -> method call
Comment 10 Dusan Balek 2012-04-23 14:28:16 UTC

*** This bug has been marked as a duplicate of bug 171183 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo