Bug 176271 - [68cat]Reparsing starts after CVS-Diff
[68cat]Reparsing starts after CVS-Diff
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
PC Windows XP
: P3 with 1 vote (vote)
: 7.0
Assigned To: Tomas Zezula
issues@editor
indexing
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 09:43 UTC by stefan79
Modified: 2016-07-07 07:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Logfile (-J-Dorg.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.level=FINE was activated) (1.29 MB, application/octet-stream)
2009-11-09 09:44 UTC, stefan79
Details
Just a test, please ignore (5 bytes, text/plain)
2009-11-09 10:01 UTC, Vitezslav Stejskal
Details
Message-Log (127.15 KB, application/octet-stream)
2009-11-09 10:40 UTC, stefan79
Details
After closing the sample-project from Bug 170976, the IDE made a total scan of all my Libraries. (245.31 KB, application/octet-stream)
2009-11-10 11:00 UTC, stefan79
Details
Message-Log (389.24 KB, application/octet-stream)
2009-11-24 10:17 UTC, stefan79
Details
Log-File (547.40 KB, application/octet-stream)
2009-11-27 04:03 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2009-11-09 09:43:04 UTC
Sometimes the IDE starts reparsing, but I don´t know why.

Following situation:
-) I clicked on a file and selected CVS/Diff
-) Then I locked at the changes
-) After I closed the Diff-Window, the IDE starts reparsing of H:/develop 
   Here are my classes.

Maybe this is a duplicate 174668 (=re-parsing while debugging).

I´ll attach logfile where "-J-Dorg.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.level=FINE" is activated.
Comment 1 stefan79 2009-11-09 09:44:16 UTC
Created attachment 90625 [details]
Logfile (-J-Dorg.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.level=FINE was activated)
Comment 2 stefan79 2009-11-09 09:46:08 UTC
(In reply to comment #0)
> -) After I closed the Diff-Window, the IDE starts reparsing of H:/develop 
>    Here are my classes.
Sorry. 
It was CVS/Search History (and not CVS/Diff).
Comment 3 Vitezslav Stejskal 2009-11-09 10:01:29 UTC
Created attachment 90626 [details]
Just a test, please ignore
Comment 4 stefan79 2009-11-09 10:40:39 UTC
Created attachment 90629 [details]
Message-Log

An other situation. 
-) I started the IDE. 
-) After Scanning Projects has finished, I made a diff on my local folders. 

After that "Scanning projects" on H:/develop starts.
Comment 5 stefan79 2009-11-10 11:00:09 UTC
Created attachment 90733 [details]
After closing the sample-project from Bug 170976, the IDE made a total scan of all my Libraries.

Then I tried to edit a file and make some changes.
Then the IDE doesn´t response and I had to kill the IDE (TaskManager).
Comment 6 Vitezslav Stejskal 2009-11-13 09:07:05 UTC
What exactly did you do when you say "I made a diff on my local folders"? I'm still trying to get my head around the log files and explain why H:/develop was scanned.

The thing is that when you do CVS/Diff it silently performs CVS/Update in order to show remote changes and this CVS/Update triggers refresh, which it should not, because it is not updating the real source file. The CVS folks promised to fix this.

But since you say that H:/develop contains *.class files and the scanning recognizes it as a binary source root I still don't understand how any CVS operation could trigger rescanning of this root (and many other binary roots as I can see in the log file). They are not under CVS controll, right? So, their rescanning is either triggered by some other action or you do CVS/Diff in the way that triggers refreshing of all scanned roots.
Comment 7 Tomas Stupka 2009-11-13 09:19:03 UTC
http://hg.netbeans.org/cdev/rev/682e40170868
Comment 8 Vitezslav Stejskal 2009-11-13 09:25:24 UTC
Tomas, thanks for fixing the silent CVS/Update.
Comment 9 stefan79 2009-11-13 09:29:22 UTC
(In reply to comment #6)
> What exactly did you do when you say "I made a diff on my local folders"? 
I´ve checked out some folders (src, test, ...) under E:/Entwicklung65.
I´ve selected the folders, that are under CVS-Control and selected CVS/Diff.

>I'm
> still trying to get my head around the log files and explain why H:/develop was
> scanned.
I also don´t understand this, but I see several time this feature.

> The thing is that when you do CVS/Diff it silently performs CVS/Update in order
> to show remote changes and this CVS/Update triggers refresh, which it should
> not, because it is not updating the real source file. The CVS folks promised to
> fix this.
Ok, I understand, but why rescanning of all roots?

> But since you say that H:/develop contains *.class files and the scanning
> recognizes it as a binary source root I still don't understand how any CVS
> operation could trigger rescanning of this root (and many other binary roots as
> I can see in the log file). 
H:/develop only contains class-Files/Properties-Files (it´s a build-dir).
There are no java-Files.
It´s defined at a library in Classpath-tabpane.

>They are not under CVS controll, right? 
Under CVS-Control is only E:/Entwicklung65

> So, their
> rescanning is either triggered by some other action or you do CVS/Diff in the
> way that triggers refreshing of all scanned roots.
??
Comment 10 Quality Engineering 2009-11-16 03:14:58 UTC
Integrated into 'main-golden', will be available in build *200911160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/682e40170868
User: Tomas Stupka <tstupka@netbeans.org>
Log: fixed the part in cvs
Issue #176271 - [68cat]Reparsing starts after CVS-Diff
Comment 11 stefan79 2009-11-24 10:17:23 UTC
Created attachment 91623 [details]
Message-Log

Same situation at 200911230200.
I made a CVS-Diff and then the Scanning-Projects started.

Please have a look at the log-file. 
org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.level=FINE was activated (I hope this helps).
Comment 12 stefan79 2009-11-27 04:03:09 UTC
Created attachment 91767 [details]
Log-File

Same "Feature" again.

I make a CVS-Diff and Scanning Projects starts at my Library-Classpath(!?!).
Comment 13 stefan79 2009-12-14 05:25:02 UTC
Is there no option to turn on a logmessage (Which class has initialized the scanning-process).
Comment 14 Vitezslav Stejskal 2009-12-15 03:50:16 UTC
(In reply to comment #13)
> Is there no option to turn on a logmessage (Which class has initialized the
> scanning-process).

No, only logs in RepositoryUpdater.
Comment 15 Martin Balin 2016-07-07 07:28:03 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo