Bug 176189 - OutOfMemoryError: Java heap space
OutOfMemoryError: Java heap space
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Bugzilla
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 03:40 UTC by Jan Becicka
Modified: 2010-02-01 06:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.92 KB, text/plain)
2009-11-09 03:40 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2009-11-09 03:40:36 UTC
Build: NetBeans IDE Dev (Build 091109-ee77cae07c32)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Linux, 2.6.25.20-0.5-default, amd64

User Comments:
jbecicka: Switch kenai instance to netbeans.org
log in.
probably all bugs from netbeans.org are being downloaded?



Stacktrace: 
java.lang.OutOfMemoryError: Java heap space
        at java.util.Arrays.copyOf(Arrays.java:2882)
        at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:100)
        at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:515)
        at java.lang.StringBuffer.append(StringBuffer.java:306)
        at org.eclipse.mylyn.internal.bugzilla.core.SaxMultiBugReportContentHandler.characters(SaxMultiBugReportContentHandler.java:90)
        at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.characters(AbstractSAXParser.java:538)
Comment 1 Jan Becicka 2009-11-09 03:40:40 UTC
Created attachment 90585 [details]
stacktrace
Comment 2 Jan Becicka 2009-11-09 06:13:32 UTC
reproducible on netbeans.org
Comment 3 Jan Becicka 2009-11-09 06:18:33 UTC
I have heapdump (500M) if you want
Comment 4 Jan Becicka 2009-11-09 08:30:37 UTC
I'm member of 
Connected Developer
IDE
Contrib
Editor
Java
Comment 5 Tomas Pavek 2009-11-09 10:37:52 UTC
I'm member of ConnectedDeveloper, Debugger, GUIBuilder, Performance and VersionControl - all together about 1,500 open issues. It took a while - cca 2-3 minutes, but all issues downloaded without a problem.

It seems all is run again after restart, taking the same time... Isn't anything supposed to be cached here?

Trying to open Java and expand Issues node shows 2274 issues after several minutes, now having close to 4,000 issues, together taking up ~250MB heap space. It's not so bad, but we can definitely get out of memory with loading too many issues.

The question is whether we can efficiently obtain the number of issues without getting the whole list. Then we can put in place some limit and don't run queries with high number of results unless explicitly opened by the user.
Comment 6 Tomas Stupka 2009-11-09 14:50:18 UTC
see two problems at the moment:
- too much memory consumed
- too many issues in this universe. need some reasonable limits...

> Trying to open Java and expand Issues node shows 2274 issues after several
> minutes, now having close to 4,000 issues, together taking up ~250MB heap
> space. It's not so bad, 
still, we should investigate if there's no leak 

> The question is whether we can efficiently obtain the number of issues without > getting the whole list.
yes. 

> Then we can put in place some limit and don't run
> queries with high number of results unless explicitly opened by the user.
xdesign on cc.
Comment 7 Tomas Stupka 2009-11-09 15:06:10 UTC
> It seems all is run again after restart, taking the same time... Isn't anything
> supposed to be cached here?
no. nothing a query rerun would benefit from
Comment 8 Jan Becicka 2009-11-10 01:18:10 UTC
The main problem I see is, that memory is consumed right after login to netbeans.org, and user cannot avoid it. This is caused by tinny number in bug dashboard. We should either drastically decrease memory consumption (e.g. as mentioned above by obtaining the number of issues without getting the whole list.) or at least provide some option not to show bug numbers right after login.
Comment 9 Tomas Stupka 2009-11-10 08:42:53 UTC
Changeset: c2e6abefe9c6
Author:    Tomas Stupka <tstupka@netbeans.org>
Date:      2009-11-10 16:42
Message:   there will be no "All Issues" query for netbeans.org
Issue #176189 - OutOfMemoryError: Java heap space
Comment 10 Tomas Stupka 2009-11-10 11:53:37 UTC
> The main problem I see is, that memory is consumed right after login to netbeans.org, and user cannot avoid it. 
fixed in #c2e6abefe9c6. Removed the "All issues" query from the nb.org dashboard as it doesn't make sense anyway. 

main problem fixed -> P3
Comment 11 Tomas Stupka 2010-02-01 06:22:02 UTC
no leaking found - closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo