Bug 175980 - NullPointerException at java.awt.Container.addNotify (MavenProblemNode cting ProblemsPanel off EQ)
NullPointerException at java.awt.Container.addNotify (MavenProblemNode cting ...
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
6.x
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: THREAD
: 174146 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-03 18:49 UTC by gaxzero
Modified: 2012-11-06 15:31 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.60 KB, text/plain)
2009-11-03 18:49 UTC, gaxzero
Details
stacktrace (3.38 KB, text/plain)
2010-04-20 22:23 UTC, dheffelfinger
Details
stacktrace (3.38 KB, text/plain)
2011-01-28 11:43 UTC, aldobrucale
Details
stacktrace (3.38 KB, text/plain)
2011-02-17 17:24 UTC, aldobrucale
Details
stacktrace (4.14 KB, text/plain)
2011-03-14 23:13 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gaxzero 2009-11-03 18:49:15 UTC
Build: NetBeans IDE 6.7.1 (Build 200907230233)
VM: Java HotSpot(TM) Client VM, 1.5.0_20-141, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_20-b02-315
OS: Mac OS X, 10.5.8, i386

User Comments:
GUEST: Using a maven2 project...
1) Did a subversion update via Netbeans (was successful)

Whilst it was running, I noticed that Netbeans was complaining about one of my pom.xml files (<Badly formed Maven project>)

2) Executed a build (mvn install) from the command line, to update any missing local artefacts.

Netbeans was still complaining about the same pom.xml file (<Badly formed Maven project>)

3) Selected "the view/resolve problem"(?) option - why is the Report Problem dialog modal?

Anyways... After selecting that option, I got no dialog to assist with finding out what the real issue is/was but saw the NullPointerException occur around the same time as I would have expected the dialog box to have appeared.

cadorca: Using the resolve problem dialog to download some libraries in a maven project

GUEST: Clicked on review and resolve issues for a maven project



Stacktrace: 
java.lang.NullPointerException
        at java.awt.Container.addNotify(Container.java:2544)
        at javax.swing.JComponent.addNotify(JComponent.java:4478)
        at java.awt.Container.addNotify(Container.java:2544)
        at javax.swing.JComponent.addNotify(JComponent.java:4478)
        at java.awt.Container.addNotify(Container.java:2544)
        at javax.swing.JComponent.addNotify(JComponent.java:4478)
Comment 1 gaxzero 2009-11-03 18:49:20 UTC
Created attachment 90463 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-11-03 18:49:25 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152426
Comment 3 Milos Kleint 2009-11-04 07:03:43 UTC
reassigning to winsys for evaluation. Did you see anything similar? a jdk issue maybe?

the affected code at org.netbeans.modules.maven.nodes.MavenProjectNode.java:280 looks like pretty much standard code.
Any advice welcome.
Comment 4 Milos Kleint 2009-11-04 13:56:23 UTC
*** Issue 174146 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Rechtacek 2009-11-11 07:48:51 UTC
Maybe it could be caused by constructing ProblemsPanel out of AWT queue in MavenProblemNode?
Comment 6 dheffelfinger 2010-04-20 22:23:02 UTC
Created attachment 97754 [details]
stacktrace
Comment 7 Antonin Nebuzelsky 2010-07-30 15:17:38 UTC
Reassigning to default owner.
Comment 8 Jesse Glick 2010-10-06 16:52:10 UTC
ProblemsPanel is constructed on EQ by ShowProblemsAction.actionPerformed, so I don't see anything wrong in maven/src code.
Comment 9 Jesse Glick 2010-10-06 16:57:21 UTC
Seems Component.peer == null. While this may ultimately be a bug in NB, AWT is doing a very poor job of reporting the source of the bug.
Comment 10 aldobrucale 2011-01-28 11:43:10 UTC
Created attachment 105430 [details]
stacktrace

Show and resolve problems on javase maven project
Comment 11 aldobrucale 2011-02-17 17:24:38 UTC
Created attachment 106122 [details]
stacktrace

Opening properties for a maven EJB project
Comment 12 Jesse Glick 2011-03-14 23:13:06 UTC
Created attachment 106996 [details]
stacktrace

"Show Problems" on a Maven project.
Comment 13 Stanislav Aubrecht 2012-11-06 15:31:47 UTC
The offending lines of code throwing the NPE have been removed in JDK 1.7


            ContainerPeer cpeer = (ContainerPeer)peer;
            if (cpeer.isRestackSupported()) {
                cpeer.restack();
            }


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo