Bug 175755 - java.lang.IncompatibleClassChangeError in HeapWalker
java.lang.IncompatibleClassChangeError in HeapWalker
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All Windows XP
: P1 (vote)
: 6.x
Assigned To: Jiri Sedlacek
issues@profiler
: REGRESSION, VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-30 11:47 UTC by Jiri Sedlacek
Modified: 2010-04-19 23:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Sedlacek 2009-10-30 11:47:48 UTC
Due to changes in recent 6u18 builds switching views in the HeapWalker causes the following exception:

java.lang.IncompatibleClassChangeError: Expected static field org.netbeans.lib.profiler.ui.UIUtils$3.dashedRectGapX
	at org.netbeans.lib.profiler.ui.UIUtils$3.paintFocus(UIUtils.java:492)
	at javax.swing.plaf.basic.BasicToggleButtonUI.paint(BasicToggleButtonUI.java:110)
	at com.sun.java.swing.plaf.windows.WindowsToggleButtonUI.paint(WindowsToggleButtonUI.java:129)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:143)
	at javax.swing.JComponent.paintComponent(JComponent.java:751)
	at javax.swing.JComponent.paint(JComponent.java:1017)
	at javax.swing.JComponent.paintChildren(JComponent.java:852)
	at javax.swing.JComponent.paint(JComponent.java:1026)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5112)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1475)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1406)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1220)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5060)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4870)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:803)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:714)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:694)
[catch] at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:125)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:117)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 Jiri Sedlacek 2009-10-30 11:49:08 UTC
Kind of regression (works fine in 6u16), affects VisualVM / Java VisualVM. The problem is on NB side where a private API
is incorrectly being used.
Comment 2 Tomas Hurka 2009-10-30 12:05:45 UTC
The problem can be reproduced also with 6u17. 
Comment 3 Tomas Hurka 2009-10-30 12:07:49 UTC
This is Windows-only problem, caused by fix of JDK bug 6657138.
Comment 5 Quality Engineering 2009-11-01 10:51:55 UTC
Integrated into 'main-golden', will be available in build *200910310201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cca8ae53d678
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #175755 - checked call to private API, do not rely on protected fields
Comment 6 dumchikov 2010-04-19 23:00:34 UTC
getting this error in JSDK's jvisualvm.exe -- profiler included with the JSDK


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo