Bug 175678 - [68cat] AssertionError at org.netbeans.modules.selenium.server.SeleniumProperties.getInstanceProperties
[68cat] AssertionError at org.netbeans.modules.selenium.server.SeleniumProper...
Status: CLOSED FIXED
Product: contrib
Classification: Unclassified
Component: Selenium
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jindrich Sedek
issues@contrib
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 176965 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 16:24 UTC by ingoreinhart
Modified: 2009-11-18 02:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (957 bytes, text/plain)
2009-10-29 16:24 UTC, ingoreinhart
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ingoreinhart 2009-10-29 16:24:36 UTC
Build: NetBeans IDE 6.8 Beta (Build 200910221137)
VM: Java HotSpot(TM) Client VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Linux, 2.6.31-14-generic, i386

User Comments:
ingoreinhart: starting NB. Have selenium for php installed



Stacktrace: 
java.lang.AssertionError
        at org.netbeans.modules.selenium.server.SeleniumProperties.getInstanceProperties(SeleniumProperties.java:77)
        at org.netbeans.modules.selenium.server.Installer.restored(Installer.java:56)
        at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:440)
        at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:361)
        at org.netbeans.ModuleManager.enable(ModuleManager.java:917)
        at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:289)
Comment 1 ingoreinhart 2009-10-29 16:24:45 UTC
Created attachment 90219 [details]
stacktrace
Comment 2 Jindrich Sedek 2009-11-09 10:25:36 UTC
fixed by d599b1732a16

Thanks for reporting it!
Comment 3 ingoreinhart 2009-11-17 01:21:29 UTC
Hi!

I retest it with build 200911161401: NOT OK

See Bug 176965
Comment 4 ingoreinhart 2009-11-17 01:22:16 UTC
*** Bug 176965 has been marked as a duplicate of this bug. ***
Comment 5 Jindrich Sedek 2009-11-18 01:28:41 UTC
The problem was that server properties were created twice by two threads and it was also writen into the userdir. Could you please delete <userdir>/config/Preferences/org/netbeans/modules/server directory and try it again? Thanks
Comment 6 ingoreinhart 2009-11-18 02:43:19 UTC
Yes! Job done.

Big Thx!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo