Bug 175564 - Support Mantis BT as Issue Tracker.
Support Mantis BT as Issue Tracker.
Status: NEW
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.0.1
All All
: P1 with 133 votes (vote)
: 7.2
Assigned To: pgebauer
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-28 02:22 UTC by maghiel
Modified: 2013-01-12 17:38 UTC (History)
7 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maghiel 2009-10-28 02:22:38 UTC
I would love to have Mantis BT added to the Issue Trackers.
Currently the only tracker available is Bugzilla?
Comment 1 maghiel 2009-10-28 02:33:54 UTC
Is there any way to change the description of this issue?
I wanted to say:
I would love to have Mantis BT added to the Issue Trackers.
Currently the only trackers available are Bugzilla and JIRA?
Comment 2 gilberto-oliveira 2009-12-01 10:33:59 UTC
I wanted that the netbeans add suport for mantis bugtracker.
Comment 3 tho48 2009-12-11 01:40:48 UTC
Mantis BT Support would be very nice.
Comment 4 avil 2010-04-14 07:49:36 UTC
yes. It would be great, if you realize mantisbt support.
Comment 5 fogster 2010-05-21 08:34:34 UTC
Mantis BT support is very much needed, would be great if you can do it...
Comment 6 ZendMania 2010-05-21 08:39:49 UTC
I hope will find it on NB7.0
Comment 7 nbphpuser 2010-05-25 20:06:17 UTC
my vote for mantis
Comment 8 rcasha 2010-06-03 05:51:53 UTC
+1 vote
Comment 9 soko 2010-06-03 22:17:43 UTC
Voted
Comment 10 ewer 2010-07-09 07:34:04 UTC
+1 Vote
Comment 11 adamgmetzler 2010-07-13 13:53:57 UTC
+1 I hope this stays on track for 6.9.1! I would love to have this so that I can use mantis from within netbeans and not through the web interface on sourceforge.
Comment 12 robmol 2010-08-05 11:49:19 UTC
+1 Vote
Comment 13 hansmantis 2010-08-05 11:52:43 UTC
+1 Vote
Comment 14 LadySerenaKitty 2010-09-16 06:15:33 UTC
I definitely want this, as I have 5 projects on my servers and having Mantis available inside NetBeans would make life so much easier.
Comment 15 luisdev 2010-10-28 07:38:56 UTC
Here's my "me too". Mantis suupport in Netbeans would be the best thing since...
Comment 16 mkash 2010-10-29 12:35:47 UTC
+1 Vote
Comment 17 aderik 2010-11-04 08:43:59 UTC
+1 Vote
Comment 18 mee2 2010-11-12 12:04:51 UTC
+1 Vote
Comment 19 Tomas Stupka 2010-11-22 09:10:58 UTC
unfortunately, due to the current resource situation in the bugtracking team a mantis plugin isn't planed for the upcoming release.
However, in case that anybody from the community want's to contribute, we are ready to provide any necessary help in means of advice and direction how to start.
Comment 20 lockheed_man 2010-12-08 09:42:18 UTC
+1
Comment 21 li0n12 2010-12-14 09:57:39 UTC
+1
Comment 22 dyadka 2010-12-16 09:22:38 UTC
I also want that the Netbeans supports the Mantis bugtracker.
Comment 23 zeuben 2010-12-31 02:37:35 UTC
+1 !!! c'mon, make 2011 as awesome as it needs to be!
Comment 24 pprokop 2011-01-15 09:55:16 UTC
+1 vote
Comment 25 Miledino 2011-01-17 10:45:02 UTC
Hello,

Can you please integrate Mantis as the issue bug tracking system in Netbeans.
This bug tracking system will help me and  other PHP developers very much.

Than you.
Comment 26 ffurlaneto 2011-02-03 11:25:21 UTC
+1 vote
Comment 27 pkremer 2011-02-05 17:26:09 UTC
+1 Vote
Comment 28 funfried 2011-02-13 14:13:50 UTC
also +1 Vote
Comment 29 marcelschiffel 2011-02-23 14:48:22 UTC
one more vote!
Comment 30 marcosjunqueira 2011-03-03 12:34:17 UTC
+1 Vote
Comment 31 scube 2011-03-08 07:58:51 UTC
+1 vote
Comment 32 B_E 2011-03-08 15:08:52 UTC
+1 vote
Comment 33 xreload 2011-03-23 20:19:41 UTC
Please add Mantis support.
Thank you.
Comment 34 gdmoss14 2011-03-29 15:54:11 UTC
Would be great.  +1 Vote
Comment 35 subdigger 2011-06-09 12:07:03 UTC
+1
Comment 36 jnfurst 2011-07-02 16:38:05 UTC
+1 Vote
Comment 37 access9 2011-07-05 13:58:57 UTC
+1 for mantis support.
Comment 38 pmartin8 2011-08-22 02:00:56 UTC
+1 vote
Comment 39 tannpv 2011-08-22 02:52:15 UTC
+1 Vote
Comment 40 nbu48d 2011-08-24 15:33:59 UTC
+1
Comment 41 franciscodiaztrepat 2011-09-20 23:19:15 UTC
+1 Vote

Not yet in Netbeans 7.0.1
Comment 42 ogmueller 2011-09-22 13:39:25 UTC
+1 vote
Comment 43 heuschkel 2011-09-23 08:29:22 UTC
+1 vote
Comment 44 siesquen 2011-09-23 16:32:44 UTC
+1 Vote
Comment 45 alex_galkin 2011-09-25 07:50:08 UTC
Integration with such easy in use (& setup) tracker would be of benefit.

+1
Comment 46 tphuocthai 2011-11-07 03:53:01 UTC
+1 vote
Comment 47 cbwd 2012-02-15 00:45:25 UTC
+1 

I think Netbeans is fantastic but not being able to integrate my IDE with my bug tracker is seriously making me think about switching to Eclipse :(
Comment 48 alied 2012-02-16 15:24:31 UTC
Hi, I've just started this project[1]:
Still, documentation is very scarse and existing working code is way too kenaish.
I would like some help on this.

[1]http://java.net/projects/nbmantisbt
Comment 49 alied 2012-02-19 04:03:41 UTC
If you can't access the project is because it is still private. More activity will help to make it public.
Comment 50 kubovy 2012-02-27 06:11:08 UTC
Vote +1
Comment 51 FienZ 2012-03-29 09:30:08 UTC
I'd love that too.
Comment 52 Elusive 2012-03-30 08:58:35 UTC
+1!
Comment 53 magnetik 2012-04-13 11:23:18 UTC
+1
Comment 54 brianjester 2012-04-17 14:35:07 UTC
Please add a Mantis plug-in for Netbeans under Issue Trackers.
Comment 55 mykbaker 2012-04-17 22:51:26 UTC
Mantis BT support would be excellent. +1
Comment 56 midgard 2012-05-04 10:44:44 UTC
+1
Comment 57 henrike 2012-05-07 23:43:09 UTC
Yes +1
Comment 58 scube 2012-05-24 10:47:16 UTC
I cant find Mantis Support in current 7.2 Beta?
Comment 59 alied 2012-05-24 13:12:46 UTC
(In reply to comment #58)
> I cant find Mantis Support in current 7.2 Beta?

no you can't ;-), but maybe will be for 7.3 if more people join in [1]. If someone is interested, send me your java.net user and I'll add you as a developer because the project is very inmature and is still private.

[1]http://java.net/projects/nbmantisbt
Comment 60 mykbaker 2012-05-25 00:40:33 UTC
alied, I'd like to help but the link isn't valid:

http://java.net/projects/nbmantisbt

Thanks, Mike
Comment 61 alied 2012-05-25 17:58:39 UTC
(In reply to comment #60)
That's why I asked to send me the your java.net user. According to java.net policies, the project is private due to its inmature state; more activity and maturity will be needed to make it public.
Actually It's in a very early stage of development because I couldn't continue for lack of documentation. There is some work and tests done but is still far from even an alpha. Al help will be appreciated, and perhaps some day (if we do it well) will be part of official Netbeans distribution (but we need first to earn it ;-))
> alied, I'd like to help but the link isn't valid:
> 
> http://java.net/projects/nbmantisbt
> 
> Thanks, Mike
Comment 62 mykbaker 2012-06-25 23:15:06 UTC
Got it, sign me up. My java.net username is mykbaker.

(In reply to comment #61)
> (In reply to comment #60)
> That's why I asked to send me the your java.net user. According to java.net
> policies, the project is private due to its inmature state; more activity and
> maturity will be needed to make it public.
> Actually It's in a very early stage of development because I couldn't continue
> for lack of documentation. There is some work and tests done but is still far
> from even an alpha. Al help will be appreciated, and perhaps some day (if we do
> it well) will be part of official Netbeans distribution (but we need first to
> earn it ;-))
> > alied, I'd like to help but the link isn't valid:
> > 
> > http://java.net/projects/nbmantisbt
> > 
> > Thanks, Mike
Comment 63 Nowres 2012-11-10 15:07:06 UTC
+1 Vote
Comment 64 matthias42 2013-01-08 12:19:15 UTC
I had a look at the mantis api through the christmas holidays and created a plugin.

http://plugins.netbeans.org/plugin/45919/mantisintegration

I found this bug report after I already pushed the plugin to the portal, so please excuse me, if I redid your efforts.

I pushed the sources for the plugin to github:

https://github.com/matthiasblaesing/netbeans-mantis-integration
Comment 65 henrike 2013-01-09 01:15:07 UTC
(In reply to comment #64)
> I had a look at the mantis api through the christmas holidays and created a
> plugin.
> 
> http://plugins.netbeans.org/plugin/45919/mantisintegration
> 
> I found this bug report after I already pushed the plugin to the portal, so
> please excuse me, if I redid your efforts.
> 
> I pushed the sources for the plugin to github:
> 
> https://github.com/matthiasblaesing/netbeans-mantis-integration

I tried installing the plugin, but it requires some dependencies, which I failed to download, Can you help me to understand what should I do to use your plugin? I have little experience in netbeans.

...Some plugins require plugin SwingX to be installed.
The plugin SwingX is requested in implementation version 201210100934.  
The plugin Issue Tracking is requested in implementation version 201210100934.  
The plugin JAX-WS 2.2 Library is requested in implementation version 201210100934.  
The following plugin is affected:       MantisIntegration ...

Thanks, Henrike.
Comment 66 gmolleda 2013-01-09 19:26:37 UTC
I see those errors when try to install the plug-in in NB 7.1.2, Then Download latest NB 7.2 and plug-in installed with no hassle. It seems 7.1 lacks a lot of other plugins, needed by MantisBT.


(In reply to comment #65)
> (In reply to comment #64)
> > I had a look at the mantis api through the christmas holidays and created a
> > plugin.
> > 
> > http://plugins.netbeans.org/plugin/45919/mantisintegration
> > 
> > I found this bug report after I already pushed the plugin to the portal, so
> > please excuse me, if I redid your efforts.
> > 
> > I pushed the sources for the plugin to github:
> > 
> > https://github.com/matthiasblaesing/netbeans-mantis-integration
> 
> I tried installing the plugin, but it requires some dependencies, which I
> failed to download, Can you help me to understand what should I do to use your
> plugin? I have little experience in netbeans.
> 
> ...Some plugins require plugin SwingX to be installed.
> The plugin SwingX is requested in implementation version 201210100934.  
> The plugin Issue Tracking is requested in implementation version 201210100934.  
> The plugin JAX-WS 2.2 Library is requested in implementation version
> 201210100934.  
> The following plugin is affected:       MantisIntegration ...
> 
> Thanks, Henrike.

(In reply to comment #65)
> (In reply to comment #64)
> > I had a look at the mantis api through the christmas holidays and created a
> > plugin.
> > 
> > http://plugins.netbeans.org/plugin/45919/mantisintegration
> > 
> > I found this bug report after I already pushed the plugin to the portal, so
> > please excuse me, if I redid your efforts.
> > 
> > I pushed the sources for the plugin to github:
> > 
> > https://github.com/matthiasblaesing/netbeans-mantis-integration
> 
> I tried installing the plugin, but it requires some dependencies, which I
> failed to download, Can you help me to understand what should I do to use your
> plugin? I have little experience in netbeans.
> 
> ...Some plugins require plugin SwingX to be installed.
> The plugin SwingX is requested in implementation version 201210100934.  
> The plugin Issue Tracking is requested in implementation version 201210100934.  
> The plugin JAX-WS 2.2 Library is requested in implementation version
> 201210100934.  
> The following plugin is affected:       MantisIntegration ...
> 
> Thanks, Henrike.
Comment 67 henrike 2013-01-09 20:16:03 UTC
Thank you gmolleda, in fact, I'm using NB 7.2 and I just upgraded the plugins, but I have the same error :(

(In reply to comment #66)
> I see those errors when try to install the plug-in in NB 7.1.2, Then Download
> latest NB 7.2 and plug-in installed with no hassle. It seems 7.1 lacks a lot of
> other plugins, needed by MantisBT.
Comment 68 djdevin 2013-01-09 20:43:57 UTC
(In reply to comment #64)

Thanks for your contribution, I was able to install this extension normally with NetBeans 7.2.1 on Linux.

But, I can't get it to connect to Mantis as it keeps telling me my password is incorrect. We have some other SOAP services consuming Mantis so I don't think our installation is to blame.
Comment 69 matthias42 2013-01-09 22:39:26 UTC
@henrike
(In reply to comment #67)
> <Problems installing because of implementation dependencies>

I had to use the implementation dependencies to access modules/classes that are only exposed that way

- SwingX: Provide a sensible date selector (the whole module is only available via friend or implementation dependency) - if anybody knows an alternative I'm in

- Bugtracking: The SPI, that needs to be implemented, is only exposed as friend api, so basicly without an implementation dependey I'm lost

- JAXB/JAXWS: Both modules provide classes needed by AXIS 1.4 (jax-rpc is not supported directly by jav)

My gut feeling tells me, that while doing the 7.2.1 release the implementation versions were changed to the mentioned version, but the corresponding modules in 7.2 were not recognized as needing an update (at least for swingx, there was no new version, so at least part of this is definitly correct).

I could produce an nbm, that works with to old implementation versions, but both versions can't coexist on the plugin portal ... (seems 7.2 == 7.2.1 *gnampf*)

Currently the only way seems to be starting from a clean installation...

@djdevin
(In reply to comment #68)
> But, I can't get it to connect to Mantis as it keeps telling me my password is
> incorrect. We have some other SOAP services consuming Mantis so I don't think
> our installation is to blame.

Could you please check your version of mantis bug tracker? The login method was added in 1.2.12 (current) - maybe I could to a build without using the mc_login method, than I think the minimum version would be 1.2.9.

@all
If you encounter bugs with my plugin, please use the issue tracker at github, let's not misuse this bug report :-)
Comment 70 alied 2013-01-12 17:38:59 UTC
Hi, I was doing one as well, but got kinda stucked on the netbeans API part. I offer my help if you need some.

(In reply to comment #64)
> I had a look at the mantis api through the christmas holidays and created a
> plugin.
> 
> http://plugins.netbeans.org/plugin/45919/mantisintegration
> 
> I found this bug report after I already pushed the plugin to the portal, so
> please excuse me, if I redid your efforts.
> 
> I pushed the sources for the plugin to github:
> 
> https://github.com/matthiasblaesing/netbeans-mantis-integration


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo