Bug 17510 - Property panel is not affirmed by focusLost
Property panel is not affirmed by focusLost
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
: FOCUS
: 30525 (view as bug list)
Depends on: 31896
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-11 10:43 UTC by Jan Becicka
Modified: 2008-12-22 18:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2001-11-11 10:43:05 UTC
[nb-beta4]
New class wizard, step 4, Create Fields:
1. create new field
2. set initial value to 0 and push Next (but do not press enter to affirm 
initial value)
3. push Back: initial value is not set.
Comment 1 Jan Becicka 2001-11-16 12:58:26 UTC
Behavior of [200111160100] on JDK1.4 is also strange:

2. set initial value to 0 and push Next. "0" is affirmed and 
selected. User has to push Next again.

Comment 2 Tomas Hurka 2001-11-20 10:31:46 UTC
fixed in trunk
Comment 3 Jan Becicka 2001-11-23 12:28:14 UTC
VERIFIED
Comment 4 Jan Becicka 2001-11-27 14:16:25 UTC
I'm afraid, I've found another testcase :-(
New class wizard, step 4, Create Fields:
1. create new field field0
2. create new field field1
3. set initial value of field1 to "0" (but do not press enter to 
affirm)
3. Using mouse select field0.
4. Select field1 again -> inital value is not set to "0"

Comment 5 jrojcek 2001-11-27 17:49:09 UTC
Another problem with PropertyPanel in Java wizard Fields panel is that
it steals focus from field list when navigating in the list by
keyboard. I expect that focus is moved in PropertyPanel.setModel call.
I think call of this method should not change focus owner.
Comment 6 Tomas Hurka 2001-11-28 08:41:02 UTC
I think I won't be fixed in release 3.3.x. To fix these problems
correctly, PropertyPanel has to be rewritten from scratch. Changing
milestone to 3.4 and assigning to issues@openide  
Comment 7 David Simonek 2002-02-05 16:15:19 UTC
PropertyPanel belongs to property editors area. Please reassign back
if I'm wrong.
Comment 8 akemr 2002-02-06 07:24:49 UTC
No, it doesn't (in openide only package
org.openide.explorer.propertysheet.editors)
Comment 9 David Simonek 2002-02-06 13:28:31 UTC
Ok, it's ours, how happy we are :-) 
Comment 10 David Simonek 2002-05-03 15:51:11 UTC
passing to property sheet guys.
Comment 11 Jiri Rechtacek 2002-06-05 09:36:07 UTC
Bad success :-( a fix of this issue looks uneasy for me. The heart of
problem is tn the method focusLost is new value set in block
invokeLater() but in meantime new property model (including noted text
field) is set --> the not stored values are lost.
Fortunately an impact on a user and frequency is small.
Comment 12 Jiri Rechtacek 2002-12-09 13:23:14 UTC
reassigning to the new subcomponent owner
Comment 13 Jan Becicka 2003-02-20 09:31:16 UTC
*** Issue 30525 has been marked as a duplicate of this issue. ***
Comment 14 Jan Becicka 2003-02-20 09:31:19 UTC
*** Issue 30525 has been marked as a duplicate of this issue. ***
Comment 15 _ tboudreau 2003-02-20 10:18:13 UTC
A major portion of PropertyPanel will be rewritten with the 
property sheet rewrite (so it uses the rendering/editor
infrastructure from the new JTable property sheet).  I'd like
to defer work on this until then - probably the rewrite will
cure the problem.  

I'm adding this issue to the property sheet rewrite umbrella
issue.
Comment 16 _ tboudreau 2003-04-14 12:43:01 UTC
Changing to block PropertyPanel rewrite umbrella issue - rewriting
PropertyPanel to use the new propertysheet's infrastructure will
come after integration of the new property sheet.
Comment 17 _ tboudreau 2003-10-24 10:18:09 UTC
Fixed on the property panel rewrite branch, and backed by a unit 
test.
Comment 18 _ tboudreau 2003-12-09 09:37:11 UTC
Property panel rewrite branch merged.
Comment 19 Marian Mirilovic 2004-08-17 08:49:50 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo