Bug 175061 - Admin Console doesn't work with download V3 server
Admin Console doesn't work with download V3 server
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
PC Windows XP x64
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-21 04:06 UTC by davisn
Modified: 2009-10-22 19:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log file (38.14 KB, text/plain)
2009-10-21 04:07 UTC, davisn
Details
server.log file (35.70 KB, text/plain)
2009-10-21 04:09 UTC, davisn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davisn 2009-10-21 04:06:38 UTC
Exception occurs when select "View Admin Console" menu for a download V3 server

Steps To Reproduce:
1. Download and install the Beta Candidate build from
http://smetiste.czech.sun.com/builds/netbeans/6.8/beta/2009-10-19_20-01-27/
2. Right-click on the Servers node, select to "Add Servers..." menu -> GlassFish V3 -> Enter a download directory ->
click Download Now button -> take default and click Finish
3. Start the download V3 Server
4. Right-click on the Server, select "View Admin Console" menu
BUG:
   The browser was launched but nothing was shown 
   FileNotFoundException occurs (log files attached)
Comment 1 davisn 2009-10-21 04:07:20 UTC
Created attachment 89812 [details]
log file
Comment 2 davisn 2009-10-21 04:09:21 UTC
Created attachment 89813 [details]
server.log file
Comment 3 Vince Kraemer 2009-10-21 06:59:36 UTC
I can replicate this issue on Win Vista with the zip file of b68, downloaded from java.net and unzipped by win vista.


I started the server.
  c:\P F\v3-b68-zip\glassfishv3\glassfish\bin\asadmin start-domain
I started the browser.
I hit the page http://localhost:4848.

The 'loading admin console' page appeared.
The browser went to an empty page.
The activity spinner stopped.

I looked in the server's log file and found the exact same stack traces.

I opened an issue in the server's tracker...

https://glassfish.dev.java.net/issues/show_bug.cgi?id=10462

It looks like v3 build 68 could be better.  
The 
Comment 4 Vince Kraemer 2009-10-21 07:02:42 UTC
Petr: pleae let me know how you want this issue 'resolved'... No change in the plugin will fix this... we need to get a
different promoted build.
Comment 5 Petr Jiricka 2009-10-21 09:58:42 UTC
Sure, let's wait for the next promoted build to see whether it will contain the fix, though I don't think this is
critical for beta. We can live with this for beta I would say.
Comment 6 Vince Kraemer 2009-10-22 19:03:40 UTC
I just verified the fix on the GF side of this with a nightly of b69... 2009-10-22...
Comment 7 davisn 2009-10-22 19:28:22 UTC
Cool and thanks Vince
Comment 8 Vince Kraemer 2009-10-22 19:56:23 UTC
just confirmed that this works when the user does download now (since b69 has been promoted).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo