Bug 174811 - Find Usages doesn't work
Find Usages doesn't work
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: J Bachorik
issues@javafx
68patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-17 15:17 UTC by Andrei Chistiakov
Modified: 2010-01-25 04:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Chistiakov 2009-10-17 15:17:14 UTC
Product Version: NetBeans IDE Dev (Build 200910160201)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

To reproduce:
- open WeatherFXApplication
- open WeatherApp.fx in Editor
- select weather1 variable declaration and invoke 'Find Usages'
- 0 occurences is found
Comment 1 J Bachorik 2009-11-17 07:44:56 UTC
I could not reproduce it with the given example. Anyhow, I was able to reproduce it with the following code snippet:
public function y() {
  var bbb : B;
  var bbbe = bbb.e;
}

I am having the fix ready but it will probably not integrated into 6.8
Comment 2 J Bachorik 2009-11-17 07:53:02 UTC
Should not have been set to fixed
Comment 3 J Bachorik 2009-12-10 03:05:51 UTC
fixed in current trunk (don't know the exact changeset but it works by http://hg.netbeans.org/javafx/rev/31392448427c)
Comment 4 Alexandr Scherbatiy 2009-12-11 04:07:37 UTC
NetBeans-JavaFX-Soma:  #62

Find Usages works for the  WeatherFX sample.
I have created a separated issue 178475 for case:

public function y() {
  var bbb : B;
  var bbbe = bbb.e;
}
Comment 5 rbalada 2010-01-21 02:34:09 UTC
The fix has been ported to release68_fixes branch 
http://hg.netbeans.org/javafx/rev/f06a9cdcf378
Comment 6 Alexandr Scherbatiy 2010-01-25 04:32:04 UTC
Verified in netbeans-6.8-201001241915-javafx-full.zip from
/builds/netbeans/6.8/fixes


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo