Bug 174564 - Deadlock opening file
Deadlock opening file
Status: RESOLVED DUPLICATE of bug 174408
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P2 (vote)
: 6.x
Assigned To: mslama
issues@platform
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-14 15:50 UTC by Jesse Glick
Modified: 2009-10-14 17:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (19.56 KB, text/plain)
2009-10-14 15:58 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-10-14 15:51:11 UTC
Thread dump shows CloneableEditor$DoInitialize.initNonVisual in RP calling NbEditorKit.call then JEditorPane.<init>,
clearly a violation of Swing threading semantics.
Comment 1 Jesse Glick 2009-10-14 15:58:14 UTC
Created attachment 89455 [details]
Thread dump
Comment 2 Jesse Glick 2009-10-14 16:05:22 UTC
In 091014/7d639b576221. Possibly caused by issue #171713.
Comment 3 mslama 2009-10-14 17:24:14 UTC

*** This issue has been marked as a duplicate of 174408 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo