Bug 174253 - Invoking Close Project during opening projects blocks AWT
Invoking Close Project during opening projects blocks AWT
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 174398 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-09 18:52 UTC by Jesse Glick
Modified: 2011-01-11 01:22 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (81.09 KB, bin/nps)
2009-10-09 18:53 UTC, Jesse Glick
Details
Thread dump - one Maven project opened (Glassfish) and attempting to close another JavaApplication (21.77 KB, text/plain)
2009-12-01 03:01 UTC, Petr Dvorak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-10-09 18:53:00 UTC
This issue was originally marked as duplicate of issue 171690, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE Dev (Build 091006)
VM: Java HotSpot(TM) Client VM, 1.5.0_20-b02, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_20-b02
OS: Linux, 2.6.28-15-generic, i386

User Comments:
jglick: Started IDE with several projects open; immediately selected them all and invoked File > Close - IDE hung.


Maximum slowness yet reported was 20582 ms, average is 20582
Comment 1 Jesse Glick 2009-10-09 18:53:06 UTC
Created attachment 89219 [details]
nps snapshot
Comment 2 Milan Kubec 2009-10-12 09:54:22 UTC
Most of the time spent in apisupport, please evaluate. Thanks.
Comment 3 Jiri Sedlacek 2009-10-31 11:13:30 UTC
Just reported http://statistics.netbeans.org/analytics/exception.do?id=291407. Took 28251 ms, this is not a P3 problem -
it makes the user think the IDE is deadlocked and must be restarted.

What about just removing the "Close" action during the initialization if the performance is not easy to/cannot be
improved? The result will be the same as invoking "Close" after initialization except that EDT won't be blocked.
Comment 4 rmichalsky 2009-11-02 13:29:50 UTC
The problem is that closing projects runs in AWT thread and waits for projects to be loaded first in background. Formal
fix would be close projects in background too, but it doesn't really save any user's time - he still needs to wait for
all the projects to be loaded and then to be closed. 

Better would be to really cancel loading projects that weren't loaded yet - don't know how big a change would that be.
Comment 5 Milan Kubec 2009-11-03 15:05:13 UTC
*** Issue 174398 has been marked as a duplicate of this issue. ***
Comment 6 Petr Dvorak 2009-12-01 03:01:43 UTC
Created attachment 91903 [details]
Thread dump - one Maven project opened (Glassfish) and attempting to close another JavaApplication
Comment 7 Jesse Glick 2010-04-13 00:04:45 UTC
At least recent snapshots seem to be about web projects doing a lot of work when opened. Perhaps some of it could be avoided or deferred.
Comment 8 David Konecny 2011-01-11 01:22:02 UTC
No reports since 6.8. Likely fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo