Bug 173926 - IDE often crashes on MacOSx
IDE often crashes on MacOSx
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
Macintosh Mac OS X
: P2 with 1 vote (vote)
: 6.x
Assigned To: issues@platform
issues@platform
:
: 175310 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-07 07:25 UTC by Martin Grebac
Modified: 2009-12-01 11:00 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
apple's crash reporter log from NB on JDK5 (67.84 KB, text/plain)
2009-10-07 07:27 UTC, Martin Grebac
Details
crash on jdk6 (81.49 KB, text/plain)
2009-10-07 10:35 UTC, Martin Grebac
Details
Message from the console. (2.93 KB, text/plain)
2009-11-05 17:08 UTC, Petr Jiricka
Details
Run this project quickly after (77.12 KB, application/x-zip-compressed)
2009-11-27 08:07 UTC, Petr Dvorak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Grebac 2009-10-07 07:25:08 UTC
I'm running NB 6.7, 6.7.1, and 6.8 dev builds, all of them crash. I thought JDK6 is the issue, but we're experiencing same kind of crashes on JDK5 as well. 
Attaching log from the apple's crash reporter.
Comment 1 Martin Grebac 2009-10-07 07:27:39 UTC
Created attachment 88964 [details]
apple's crash reporter log from NB on JDK5
Comment 2 Martin Grebac 2009-10-07 07:49:17 UTC
Just to add that the crash dump is from running NB 6.7.1 as it's not obvious from the log.
Comment 3 Martin Grebac 2009-10-07 10:35:49 UTC
Created attachment 88985 [details]
crash on jdk6
Comment 4 Filip Zamboj 2009-10-19 12:13:28 UTC
could you point us a bit more, please? What kind of projects are you running when crash occurs? Is there some action you
invoke and you experience crash afterwards? 

Thanks a lot! 
Comment 5 Petr Jiricka 2009-11-05 17:06:35 UTC
I am also getting this from time to time. Just now it happened when I was switching back to NetBeans from another
application. I had a few Java projects open, a few NB module projects + one suite, and one web project. Here is my
version info:

  Product Version         = NetBeans IDE Dev (Build web-main-2018-on-091105) (#222a3267d8e1)
  Operating System        = Mac OS X version 10.5.8 running on x86_64
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) 64-Bit Server VM 14.1-b02-92; Apple Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_15-b03-226

I am attaching the message from the console. What other information would help?
Comment 6 Petr Jiricka 2009-11-05 17:08:18 UTC
Created attachment 90526 [details]
Message from the console.
Comment 7 Peter Pis 2009-11-13 03:48:02 UTC
Reassigning for further evaluation.
Comment 8 Antonin Nebuzelsky 2009-11-20 04:53:43 UTC
*** Bug 175310 has been marked as a duplicate of this bug. ***
Comment 9 Martin Grebac 2009-11-20 05:23:20 UTC
FYI, I submitted Apple bug #7282670. There's no new info in the bug though, they asked me to replicate the bug with latest patch even though I had the patch installed already anyway.
Comment 10 Antonin Nebuzelsky 2009-11-20 05:52:00 UTC
What I heard from people who are experiencing the crashes (pjiricka, mgrebac, joshis) is that it is happening totally randomly - can happen three times a week and then does not happen for a month, also it is happening at unpredictable moments, the only moment that some people saw it happen more often is when NetBeans is not focused and then gets focus.

I will try escalating the apple bug mgrebac filed.

Keeping open with TM=6.8 for now, but I assume this bug will be closed as WONTFIX soon with the link to the Apple bug.

Please, add more comments here if you have some new observations.
Comment 11 nehalem 2009-11-20 09:16:46 UTC
(In reply to comment #10)
> What I heard from people who are experiencing the crashes (pjiricka, mgrebac,
> joshis) is that it is happening totally randomly - can happen three times a
> week and then does not happen for a month, also it is happening at
> unpredictable moments, the only moment that some people saw it happen more
> often is when NetBeans is not focused and then gets focus.
> 
> I will try escalating the apple bug mgrebac filed.
> 
> Keeping open with TM=6.8 for now, but I assume this bug will be closed as
> WONTFIX soon with the link to the Apple bug.
> 
> Please, add more comments here if you have some new observations.

Very good observations.  The times we've noticed it most is when switching from netbeans to firefox for web development, so the on focus stuff makes a lot of sense (6 developers and all have this problem, although the guy on Leopard seems to have less crashes).  I've never seen near a month, and nobody else here has either.  My record is five crashes in one day, and I've probably topped out at 3 days without a crash.  I would say nobody else here has had that many in one day (lucky I guess), but they've never had better than a work week.

I really hope this can be taken care of, as it makes netbeans is very hard to use on a mac (having to reopen all your files for editing and having your project tree reset is very, very annoying).  I really love the IDE too (admittedly I've tried Eclipse many times to avoid the constant crashes and find it's far too difficult to setup right).

What I don't get is why is this the only java app I use that has this problem?  I get that it's a JVM crash but can anything be done in the near term to address it from the program end?

Also I'll add we've tried to do EVERYTHING.  We've switched back to the old jvm, got rid of the JNI stuff (we saw it posted somewhere), and the crashes continue.
Comment 12 nehalem 2009-11-20 09:24:05 UTC
How do you view apple bugs?  I only see a way to report them and view ones you've filed with them.
Comment 13 Petr Dvorak 2009-11-21 06:51:33 UTC
#12: As Apple is the most opened platform in the world, the answer is "You don't" (you cannot access Apple's bug database)

My IDE crashed yesterday while I was editing a Java source code, no switching at all. The problem occurred when I repeatedly invoked code completion, which I did because I had the feeling that the list of suggestions did not contain an item it should contain... But maybe this is false lead... As I was on the train, I was unable to report the bug to apple using the Crash report tool.
Comment 14 Petr Jiricka 2009-11-23 01:49:45 UTC
> Keeping open with TM=6.8 for now, but I assume this bug will be closed as
> WONTFIX soon with the link to the Apple bug.

I would prefer to keep it open and waive it for 6.8, so it does not disappear from our radar and we continue to push for a fix on Apple's side.
Comment 15 Antonin Nebuzelsky 2009-11-23 07:44:28 UTC
An answer from Apple Java engineers I got through my point of contact:

Users are seeing two different issues based on the two stack traces attached to this bug.

1) Crash 1:

Thread 23 Crashed:
0   com.apple.CoreFoundation          0x00007fff83dba85e CFRelease + 30
1   com.apple.CoreGraphics            0x00007fff80dca9c4 textStateRelease + 36
2   com.apple.CoreGraphics            0x00007fff80dccd42 CGGStateRelease + 64
3   libawt.jnilib                     0x0000000138bba718 -[AWTDrawableContextManager setupContextState:] + 1709
4   libawt.jnilib                     0x0000000138bb9deb -[AWTDrawableContextManager getContext:canDrawDuringLiveResize:] + 400
5   libawt.jnilib                     0x0000000138bbefa1 ViewSD_Lock + 163
6   libawt.jnilib                     0x0000000138bc39eb Java_sun_java2d_loops_FillRect_FillRect + 296
7   ???                               0x0000000102c4f00a 0 + 4341428234
8   ???                               0x0000000102c50e58 0 + 4341435992

This issue has been fixed in an update Apple folks are just about to release. It is a duplicate of Apple bug 6610795.

2) Crash 2:

The second issue for which the Apple bug 7282670 was filed is a hotspot issue, which Apple engineers have asked the reporter to verify with the latest update.

Thread 22 Crashed:
0   libclient.dylib                   0x498882 Chunk::chop() + 18
1   libclient.dylib                   0x498864 Chunk::next_chop() + 20
2   libclient.dylib                   0x59a283 HandleMark::~HandleMark() + 35
3   libclient.dylib                   0x6b87a9 Thread::~Thread() + 73
4   libclient.dylib                   0x6b8f9f JavaThread::~JavaThread() + 287
5   libclient.dylib                   0x416f72 JavaThread::thread_main_inner() + 50
6   libclient.dylib                   0x67f4f5 _start + 53
7   libSystem.B.dylib                 0x947c1200 _pthread_body + 27

Martin, you filed 7282670. Can you please try the latest Java update from connect.apple.com ASAP and follow up with them in the Apple bug you filed? My understanding is that connect.apple.com contains a testing Java update which should fix also this Crash 2. And note also here, what's the status of that bug. Thanks.
Comment 16 Martin Grebac 2009-11-23 08:10:18 UTC
I see. I got info in the bug that there's some kind of update ready, but they provided a link to a public update which I had already installed, so that didn't fix anything. 
So now I downloaded the latest update I see, listed as:
Java for Mac OS X 10.5 Update 6 - 9M3113 (Disk Image)	 122.6 MB	27 Oct 2009
and will give it a try, even though bug number 7282670 is not in the list of fixed issues. Would you please check if I'm using the right update? Thanks.
Since the issue is undeterministic I'd have to use it more to assure the crashes are really fixed.
Comment 17 Antonin Nebuzelsky 2009-11-24 02:57:06 UTC
> Would you please check if I'm using the right update?

I have an answer from the guys: "The latest preview we have on ADC seems to be a month old unfortunately, but it would be good to know if it fixes the problem."

Martin, can you run with the update for a day or two and let me know here if it seems to be stable? If you encounter the crash again, I will ask them to provide a new update as soon as possible.
Comment 18 Petr Dvorak 2009-11-27 08:06:46 UTC
OK, now my IDE crashed like 3 times in 5 minutes.

I was developing a small demo project for a NetBeans user and I run it very often to do small incremental fixes. I just did some change of number (5 to 10, for example), I run the app, then I was dissatisfied, so I closed the app, changed 10 to 7, run it again... over and over again...

Attaching the project
Comment 19 Petr Dvorak 2009-11-27 08:07:57 UTC
Created attachment 91786 [details]
Run this project quickly after
Comment 20 Petr Dvorak 2009-11-27 08:09:17 UTC
Run the above project quickly after each run, change the location of drawn text before each run...
Comment 21 Petr Dvorak 2009-11-27 08:19:05 UTC
Not reproducible with a fresh userdir... Maybe it is related to the classes cache accessing (before I deleted userdir, my cache dir must have been quite large)?
Comment 22 capdog 2009-11-27 10:15:37 UTC
Installing the latest Java update preview from connect.apple.com has fixed it for me!
Comment 23 Martin Grebac 2009-12-01 07:02:36 UTC
I installed the patch from apple and so far running for about a week without crash. Hopefully this is fixed.
Comment 24 Antonin Nebuzelsky 2009-12-01 10:26:23 UTC
capdog, martin, thanks for the confirmation!

I believe now the issue can be closed as WONTFIX with the note that it is not fixed in NetBeans code but in Apple's JDK.

For reference - the bugs in Apple bug database are #6610795 and #7282670.
Comment 25 nehalem 2009-12-01 11:00:16 UTC
I can confirm that it works for me as well with the new JVM.  It's been so nice to have a working IDE again.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo