Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 173363 - New line breaks code
New line breaks code
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Miloslav Metelka
issues@javafx
NO68_BETA
:
Depends on:
Blocks: 130138
  Show dependency treegraph
 
Reported: 2009-09-30 10:12 UTC by Alexandr Scherbatiy
Modified: 2009-11-17 07:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2009-09-30 10:12:02 UTC
Product Version         = NetBeans IDE 6.8 Beta (Build 200909281634) (#066b555e5ecf)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02; Sun Microsystems Inc.



Steps to reproduce:

- Copy the code to the editor:
------------------------------------------------------
var names = ["Petr"];
------------------------------------------------------

- Position cursor before "Petr" string
------------------------------------------------------
var names = [|"Petr"]; // | means cursor
------------------------------------------------------

- Press Enter

The result is:
------------------------------------------------------
var names = ["  
""Petr"];
------------------------------------------------------


Main.fx:11: Unterminated string literal - missing ' or ".
var names = ["
Main.fx:12: Unterminated string literal - missing ' or ".
""Petr"];
Main.fx:12: It looks like you are missing a ',' delimiter or perhaps have a malformed expression here?
""Petr"];
Main.fx:12: Sorry, I was trying to understand a sequence creation expression but I got confused when I hit the end of
the script..
 Perhaps you are missing a ']'.
""Petr"];
4 errors
Comment 1 Miloslav Metelka 2009-11-14 11:40:20 UTC
http://hg.netbeans.org/javafx/rev/37b96a7dde3b
Comment 2 Alexandr Scherbatiy 2009-11-17 07:29:59 UTC
verified in Build 200911170201


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo