Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171947 - After about 30 compiles GlassFish fired an OutOfMemoryError error
After about 30 compiles GlassFish fired an OutOfMemoryError error
Status: RESOLVED INVALID
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
All Windows XP
: P2 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
:
: 165341 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 15:59 UTC by masha
Modified: 2009-09-17 19:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description masha 2009-09-10 15:59:08 UTC
After about 30 compiles GlassFish fired an OutOfMemoryError error.
I dint't changed application.xml before this error appeared, as is said on forum, just recompiled for many times (have
changed code)

StandardWrapperValve[RemoteJmxConnectorServlet]: PWC1406: Servlet.service() for servlet RemoteJmxConnectorServlet threw
exception
java.lang.OutOfMemoryError: PermGen space
PWC3989: An exception or error occurred in the container during the request processing
java.lang.OutOfMemoryError: PermGen space
PWC3989: An exception or error occurred in the container during the request processing
java.lang.OutOfMemoryError: PermGen space
PWC3989: An exception or error occurred in the container during the request processing
java.lang.OutOfMemoryError: PermGen space
PWC3989: An exception or error occurred in the container during the request processing
java.lang.OutOfMemoryError: PermGen space
StandardWrapperValve[RemoteJmxConnectorServlet]: PWC1406: Servlet.service() for servlet RemoteJmxConnectorServlet threw
exception
java.lang.OutOfMemoryError: PermGen space
WEB0756: Caught exception during HTTP processing.
java.lang.OutOfMemoryError: PermGen space
StandardWrapperValve[RemoteJmxConnectorServlet]: PWC1406: Servlet.service() for servlet RemoteJmxConnectorServlet threw
exception
java.lang.OutOfMemoryError: PermGen space
Comment 1 masha 2009-09-10 16:45:47 UTC
Heavy system! Reboot of IDE didn't helped. I have had to reboot the whole computer! :D
Comment 2 Peter Pis 2009-09-11 08:26:47 UTC
Reassigning.
Comment 3 Vince Kraemer 2009-09-11 15:31:47 UTC
this looks pretty serious...  I will dig into it.
Comment 4 Vince Kraemer 2009-09-11 17:13:25 UTC
please describe the application that you are working on when this happens...

about how big is it (as a deployable archive)?

what kind of app is it... war or ear?

what java ee version is it code against ee 5, ee 6, j2ee 1.4?

That kind of info will help me reproduce the problem.
Comment 5 masha 2009-09-11 19:03:47 UTC
1. didn't understand exactly a question, but
- size of "war" folder is 1,02 MB (1.073.152 bytes),
- in debug mode it is shown 65,6 / 90,1 Mb,
- in Servers > Glassfish v2.1 > Applications > Web applications > my project > properties - haven't found any records
about size.

2. war. The project is Spring MVC + GWT framework.

3. JDK 1.6.0_12
Comment 6 Vince Kraemer 2009-09-11 19:14:14 UTC
is this gf v3 or gf v2.1?
Comment 7 masha 2009-09-14 09:16:30 UTC
2.1
Comment 8 Vince Kraemer 2009-09-14 22:45:09 UTC
I tried to reproduce this on Solaris... but was not able to do it.

I created a web app project that uses the Spring MVC framework.

I created a couple of Spring MVC artifacts in the project.

I used the Deploy item on the project's right-click menu about 40 times.

I changed strategy..

I started making minor changes in one of the Spring MVC artifact's source files and saving the change.  This put 'Deploy
on Save' through the test.

I did 40 redeployments, triggered by an edit/save in the source code for the project.

Still I did not see a OOM.

I will try my Windows Vista box tonight.
Comment 9 doctorlux 2009-09-15 00:02:28 UTC
This is a very old and annoying issue since glassfish v1 and still persisting. It happens after many redeploys of EAR or
WAR in short period. Deploy on save just speed up the process. The only workaround found is to increase MaxPermSize in
jvm options on glassfish.

And one more thing, you don't have to restart you computer, just have to kill java process of glassfish, because of
PermGen it can't be stoped by asadmin command.
Comment 10 Petr Hejl 2009-09-15 13:05:41 UTC
I think this a variation of famous PermGen OOME. This is related to JVM design and the way how some frameworks
manipulate/generate classes. I doubt it is related to NetBeans. Perhaps GF could do something about that.

One of many blogs on this: http://www.jroller.com/agileanswers/entry/preventing_java_s_java_lang
Comment 11 Vince Kraemer 2009-09-16 20:44:01 UTC
*** Issue 165341 has been marked as a duplicate of this issue. ***
Comment 12 Vince Kraemer 2009-09-17 19:59:28 UTC
OK.

There is not much the plugin can 'do' about this, since the Permgen issue is really a bug in the way the server
interacts with your app.

There is an open issue for v2.1 for this problem: https://glassfish.dev.java.net/issues/show_bug.cgi?id=5104

There is a similar issue open against v3: https://glassfish.dev.java.net/issues/show_bug.cgi?id=6082.

After reading though both issues, it seems like you may have 'more joy' (== fewer PermGen issues) by trying to use
recent builds of GF v3... See https://glassfish.dev.java.net/issues/show_bug.cgi?id=6082#desc25 and
https://glassfish.dev.java.net/issues/show_bug.cgi?id=6082#desc27

Since the plugin cannot do much about the problem, I am going to close this issue as INVALID (in the context of this
issue tracker and code base), there are entries in the trackers where this issue should be tracked.

I opened issue 172518 to track an enhancement to the Stop action in the v2 plugin.  I also opened issue 172518 for the
v3 plugin


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo