Bug 171926 - Patch for: Code Templates Options should be in SplitPane
Patch for: Code Templates Options should be in SplitPane
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
All All
: P3 (vote)
: 7.4
Assigned To: Dusan Balek
issues@editor
: PATCH_AVAILABLE, USABILITY
: 202803 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 14:01 UTC by maxnitribitt
Modified: 2013-07-10 21:34 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Proposed patch (17.02 KB, patch)
2013-06-21 12:14 UTC, markiewb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description maxnitribitt 2009-09-10 14:01:18 UTC
The Options -> Editor -> Code Templates Window would benefit from a SplitPane. Currently (on Ubuntu) I see a small area
on top reserved for a table and a large JTabbedPane (Expanded Text / Description) that takes most of the screen real
estate for displaying typically 1-3 line of text. 

Expected layout:
The table should make use of screen real estate by default and grow when resizeing. A splitpane could be used to make
the two parts resizeable.
Comment 1 Vitezslav Stejskal 2009-09-11 11:36:37 UTC
Makes sense. Thanks
Comment 2 markiewb 2013-05-02 18:55:59 UTC
*** Bug 202803 has been marked as a duplicate of this bug. ***
Comment 3 markiewb 2013-06-21 12:14:20 UTC
Created attachment 136136 [details]
Proposed patch

I like to propose a patch to solve the issue. The patch adds a vertical JSplitPane to the panel. Nothing more. No logic has been changed. The patch looks big, but I only moved the widgets within the GUI builder.

@Dusan: Please review and commit, if appropriate. 
BTW: In general do you (and the other devs) still accept patches of usability issues for 7.4?
Comment 4 Dusan Balek 2013-06-21 17:14:45 UTC
Patch integrated. Thanks for your contribution!

http://hg.netbeans.org/jet-main/rev/7f094b33690e
Comment 5 Quality Engineering 2013-06-23 02:09:09 UTC
Integrated into 'main-golden', will be available in build *201306222301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7f094b33690e
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #171926: Code Templates Options should be in SplitPane (contributed by markiewb@netbeans.org).
Comment 6 markiewb 2013-07-10 21:34:35 UTC
Verified in 201307011244.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo