Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 170740 - installing fast ruby debugger on mac fails - does not ask for root permissions
installing fast ruby debugger on mac fails - does not ask for root permissions
Status: RESOLVED DUPLICATE of bug 128575
Product: ruby
Classification: Unclassified
Component: Debugger
6.x
Macintosh All
: P3 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-21 09:06 UTC by Tomas Danek
Modified: 2009-08-21 10:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2009-08-21 09:06:18 UTC
Product Version: NetBeans IDE Dev (Build 200908171401)
Java: 1.5.0_19; Java HotSpot(TM) Client VM 1.5.0_19-137
System: Mac OS X version 10.5.8 running on i386; MacRoman; en_US (nb)
Userdir: /Users/tomas/.netbeans/dev
---------------
- open Ruby platform manager
- choose native ruby
- hit "install fast debugger"
--> installation fails, gem needs to write to /usr/bin. 

Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions into the /usr/bin directory.

would be nice to have something similar like on linux - to invoke "sudo dialog" and run gem command as root.
Comment 1 Martin Krauskopf 2009-08-21 10:34:57 UTC
This is being solved in issue #128575. Mac still unsolved, since it is (or seems to be) a harder case (no gksu by
default, see the #128575). If you have any insight please comment in the #128575. Thanks.

*** This issue has been marked as a duplicate of 128575 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo